Bug 972949 - 'mod_proxy_balancer' algorithm 'bybusyness' does not balance the load after failed worker has recovered
'mod_proxy_balancer' algorithm 'bybusyness' does not balance the load after f...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: httpd (Show other bugs)
6.4
All Linux
high Severity high
: rc
: ---
Assigned To: Web Stack Team
Filip Holec
: Patch
Depends On:
Blocks: 994246 1056252
  Show dependency treegraph
 
Reported: 2013-06-10 17:26 EDT by Josep 'Pep' Turro Mauri
Modified: 2016-04-18 06:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: httpd-2.2.15-31.el6
Doc Type: Bug Fix
Doc Text:
Cause: When using mod_proxy_balancer with lbmethod_bybusyness, the "busy" counter was not decreased when the worker tried to send a request to non-working node. Consequence: Once the non-working node became working again, mod_proxy_balancer did not recover the worker, because the "busy" counter still signalled the worker is busy. Fix: The "busy" counter is decreased after failed requests. Result: mod_proxy_balancer uses the worker after the node recovery.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:07:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 48735 None None None Never

  None (edit)
Description Josep 'Pep' Turro Mauri 2013-06-10 17:26:03 EDT
Description of problem:
Apache 'mod_proxy_balancer' algorithm 'bybusyness' does not balance the load after failed worker has recovered. This issue does not occur with the default method (byrequests).

Version-Release number of selected component (if applicable):
httpd-2.2.15-28.el6_4

How reproducible:
Always

Steps to Reproduce:
see bug 601132 or upstream bug report

Additional info:
This was reported in EWS in bug 899273
Comment 11 errata-xmlrpc 2014-10-14 04:07:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1386.html

Note You need to log in before you can comment on or make changes to this bug.