Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 972953 - synced role names are based on spacewalk org ID instead of org name
Summary: synced role names are based on spacewalk org ID instead of org name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Subscription Asset Manager
Classification: Retired
Component: Splice
Version: 1.3
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: James Slagle
QA Contact: mkovacik
URL:
Whiteboard:
Depends On:
Blocks: sam13-tracker
TreeView+ depends on / blocked
 
Reported: 2013-06-10 22:01 UTC by Chris Duryee
Modified: 2013-10-01 10:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-01 10:55:52 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1390 0 normal SHIPPED_LIVE Release 1.3 of Subscription Asset Manager 2013-10-01 14:43:14 UTC

Description Chris Duryee 2013-06-10 22:01:22 UTC
Description of problem:

This bug was re-introduced as part of the fix for https://bugzilla.redhat.com/show_bug.cgi?id=972146.

After a successful run of spacewalk-splice-tool --spacewalk-sync, the role names in SAM are of the form "Org Admin for satellite-#", instead of "Org Admin for <Name of org>". This works ok if Satellite 5.6 is the gold copy of the role data, but if someone wanted to add a SAM-only user later on with the "Org Admin" role, this would cause some confusion since they'd have to look it up by label instead of name.

Version-Release number of selected component (if applicable): 0.19


How reproducible: every time


Steps to Reproduce:
1. run spacewalk-splice-tool --spacewalk-sync
2. observe role names in SAM UI

Actual results: role names are of the form "Org Admin for satellite-#"


Expected results: role names should be "Org Admin for <name of org>"


Additional info: This bug is a result of the fix for https://bugzilla.redhat.com/show_bug.cgi?id=972146, which is more severe.

Comment 1 James Slagle 2013-06-19 13:40:53 UTC
sst commit e11fdaa0c89eab687378a2bc769dc81ee7329146

role names are now named with the satellite org name instead of satellite org id.
handles org renames as well.

Comment 2 Vitaly Kuznetsov 2013-06-21 14:41:22 UTC
Verified in spacewalk-splice-tool-0.24-1.el6sam.x86_64

Comment 4 errata-xmlrpc 2013-10-01 10:55:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html


Note You need to log in before you can comment on or make changes to this bug.