Bug 972956 - More AVC denials when using netns
More AVC denials when using netns
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.4
All Linux
urgent Severity urgent
: rc
: 6.5
Assigned To: Miroslav Grepl
Michal Trunecka
: ZStream
Depends On:
Blocks: 971493 976000
  Show dependency treegraph
 
Reported: 2013-06-10 18:19 EDT by Terry Wilson
Modified: 2014-09-30 19:35 EDT (History)
9 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-205.el6
Doc Type: Bug Fix
Doc Text:
When using Quantum 2013.1.2 with netns support, several SELinux denials were produced. This update allows qemu to manage nova lib files, hald to read svirt images, and AVC denials no longer occur in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 05:30:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ausearch -i -m avc output (2.79 KB, text/plain)
2013-06-10 18:26 EDT, Terry Wilson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1598 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2013-11-20 16:39:24 EST

  None (edit)
Description Terry Wilson 2013-06-10 18:19:17 EDT
Description of problem:

When using Quantum 2013.1.2 with netns support, several SELinux denials are produced.

Version-Release number of selected component (if applicable):

selinux-policy-3.7.19-195.el6_4.10.noarch

How reproducible:

Always

Steps to Reproduce:
1. Install openstack via packstack on a RHEL 6.4 VM with the 2013-06-10.1 puddle
2. Log into the installed target VM and:
   quantum net-create net1
   quantum subnet-create net1 10.0.0.0/24 --name subnet1
   Log into horizon and create a keypair and image (I used https://launchpad.net/cirros/trunk/0.3.0/+download/cirros-0.3.0-x86_64-disk.img)
   Launch an instance using the cirros image
3. Witness the avc denials

Actual results:

AVC denials:
type=AVC msg=audit(1370900696.344:2773): avc:  denied  { read } for  pid=4326 comm="qemu-kvm" name="disk" dev=dm-0 ino=7303 scontext=system_u:system_r:qemu_t:s0-s0:c0.c1023 tcontext=system_u:object_r:nova_var_lib_t:s0 tclass=file
type=AVC msg=audit(1370900696.344:2773): avc:  denied  { open } for  pid=4326 comm="qemu-kvm" name="disk" dev=dm-0 ino=7303 scontext=system_u:system_r:qemu_t:s0-s0:c0.c1023 tcontext=system_u:object_r:nova_var_lib_t:s0 tclass=file
type=AVC msg=audit(1370900696.349:2774): avc:  denied  { ioctl } for  pid=4326 comm="qemu-kvm" path="/var/lib/nova/instances/d326667b-2b03-4449-9f26-ad49766c0512/disk" dev=dm-0 ino=7303 scontext=system_u:system_r:qemu_t:s0-s0:c0.c1023 tcontext=system_u:object_r:nova_var_lib_t:s0 tclass=file
type=AVC msg=audit(1370900696.349:2775): avc:  denied  { getattr } for  pid=4326 comm="qemu-kvm" path="/var/lib/nova/instances/d326667b-2b03-4449-9f26-ad49766c0512/disk" dev=dm-0 ino=7303 scontext=system_u:system_r:qemu_t:s0-s0:c0.c1023 tcontext=system_u:object_r:nova_var_lib_t:s0 tclass=file
type=AVC msg=audit(1370900696.349:2776): avc:  denied  { write } for  pid=4326 comm="qemu-kvm" name="disk" dev=dm-0 ino=7303 scontext=system_u:system_r:qemu_t:s0-s0:c0.c1023 tcontext=system_u:object_r:nova_var_lib_t:s0 tclass=file


Expected results:

No AVC denials

Additional info:

I haven't noticed anything not working because of the denials.
Comment 1 Terry Wilson 2013-06-10 18:26:10 EDT
Created attachment 759386 [details]
ausearch -i -m avc output
Comment 12 errata-xmlrpc 2013-11-21 05:30:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1598.html

Note You need to log in before you can comment on or make changes to this bug.