Bug 972959 - Anaconda F19-TC-2 is unable to regain focus of the network configuration box if it loses it
Anaconda F19-TC-2 is unable to regain focus of the network configuration box ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
RejectedBlocker AcceptedFreezeException
:
Depends On:
Blocks: F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-06-10 18:43 EDT by Dan Mashal
Modified: 2013-07-15 05:35 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-19.30.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 02:15:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mashal 2013-06-10 18:43:53 EDT
Tested on F19 Final TC-2 DVD

How to reproduce:

1) Boot F19 go to network configuration click configure. Click outside of the box
2) Lose focus of the network configuration box
3) Notice that configure is greyed out
4) Click done
5) Network configuration box is shown on the main screen
6) Click somewhere else on the main screen and lose focus of it again

Results:

Impossible to regain focus of network configuration.
Comment 1 Adam Williamson 2013-06-10 20:55:28 EDT
Confirmed, it sure does behave badly. Looks like it's not 'captured' in any way like the dialogs on partitioning (for e.g.) are. I'm at least +1 FE to this, and I think that'd be uncontroversial, for anaconda team's benefit.
Comment 2 Radek Vykydal 2013-06-11 10:36:06 EDT
We still don't have solution for the issue, the main problem is that the network configuration window belongs to a separate process (nm-connection-editor). There already is bug #876020 filed.

However, Vratislav came up with IMO reasonable idea for workaround - don't make Configure button insensitive when nm-c-e is run, rather allow clicking the button to kill any existing (in this case hidden) dialog and run a new one.

Here is updates image to try with TC-2:
http://rvykydal.fedorapeople.org/updates.nmcefocus.img
Comment 3 Dan Mashal 2013-06-11 12:27:32 EDT
How about alt+tab? How about combining the network spoke and the location time zone? Maybe that might save some memory and time left taking to configure the install? How about moving it to the main screen? How about not greying out the configure button when the window is open? That way when you click the configure button it just reactivates the window?

All reasonable thoughts.
Comment 4 Adam Williamson 2013-06-11 18:59:19 EDT
"How about alt+tab? How about combining the network spoke and the location time zone? Maybe that might save some memory and time left taking to configure the install? How about moving it to the main screen?"

How would any of those thoughts help anything at all? The fundamental issue is that it's launching a separate process, and that's coming up as a proper window, and we can't make it a 'captured' (don't know the right term) window like the partitioning ones are because it's really a separate process, and one that's a fully-fledged app in its own right (nm-c-e). Nothing you mentioned there would help at all.

"How about not greying out the configure button when the window is open?"

That's, erm, precisely what Radek wrote, and what the updates image he posted does.
Comment 5 Radek Vykydal 2013-06-12 04:58:58 EDT
For the record, Alt+Tab functionality was intentionally removed (bug #858686).
Comment 6 Adam Williamson 2013-06-12 12:26:26 EDT
Discussed at 2013-06-12 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-12/f19final-blocker-review-5.2013-06-12-16.01.log.txt . The general feeling on this was that it's not likely to come up enough or screw people up badly enough to be a blocker (it doesn't directly hit any of the criteria, so it'd be a very conditional violation of 'must be able to install'), but it's accepted as a freeze exception issue.
Comment 7 Radek Vykydal 2013-06-13 13:41:19 EDT
Screencasts:
current behaviour: http://rvykydal.fedorapeople.org/nmcestacking_current.webm
patched: http://rvykydal.fedorapeople.org/nmcestacking.webm
Comment 8 Fedora Update System 2013-06-14 12:44:54 EDT
pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19
Comment 9 Dan Mashal 2013-06-15 11:51:06 EDT
(In reply to Radek Vykydal from comment #7)
> Screencasts:
> current behaviour: http://rvykydal.fedorapeople.org/nmcestacking_current.webm
> patched: http://rvykydal.fedorapeople.org/nmcestacking.webm

Loosk good!
Comment 10 Fedora Update System 2013-06-15 13:06:37 EDT
Package anaconda-19.30.7-1.fc19, pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30.7-1.fc19 pykickstart-1.99.32-1.fc19 python-blivet-0.16-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10913/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.7-1.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-06-18 02:15:39 EDT
pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19, anaconda-19.30.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.