Bug 972970 - "Partial RELRO" not detected
Summary: "Partial RELRO" not detected
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hardening-check   
(Show other bugs)
Version: 18
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-10 23:59 UTC by Harald Reindl
Modified: 2013-06-11 22:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 06:18:06 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
archive with screenshot and two hardening-checkers (55.14 KB, application/octet-stream)
2013-06-10 23:59 UTC, Harald Reindl
no flags Details

Description Harald Reindl 2013-06-10 23:59:39 UTC
Created attachment 759390 [details]
archive with screenshot and two hardening-checkers

first thank you for the fedora-package

what i am missing is "Partial RELRO" which is detected by a perl script found the last days and actually i was able to change the output of some private packages from "Partial RELRO" to a green "Full RELRO"

attached a screnshot and both of my script called by "hardening-check.sh" to see the difference - the perl script seem to do a better job here and maybe something could be patched into "hardening-check" - the colored output would also be nice :-)

Comment 1 Björn 'besser82' Esser 2013-06-11 06:18:06 UTC
Thanks for your bug-report, in return. :)

The "Partial RELRO" issued by check-security.sh, is perfectly the same as hardening-check reporting: "RELRO: yes, Immediate Binding: no".  See [1] for further reference.

For colored output you can use --color switch.  More options are described in hardening-check's manpage and/or --help output.

I'll close here --> NOTABUG

[1] http://tk-blog.blogspot.de/2009/02/relro-not-so-well-known-memory.html

Comment 2 Harald Reindl 2013-06-11 22:26:24 UTC
got it - thank you

well, looks like you packacged "checksec" too - fine :-)
http://koji.fedoraproject.org/koji/buildinfo?buildID=426028
________________________________________________

[harry@srv-rhsoft:~]$ cat /usr/local/bin/hardening-check 
#!/usr/bin/bash
/usr/bin/hardening-check --color $1
echo ""
/usr/bin/checksec --file $1


Note You need to log in before you can comment on or make changes to this bug.