Bug 972974 - Incorporate new UI Plugin Information into Admin Guide
Incorporate new UI Plugin Information into Admin Guide
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Zac Dover
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 20:27 EDT by Zac Dover
Modified: 2015-09-22 09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zac Dover 2013-06-10 20:27:52 EDT
Objective
---------
Incorporate new material about UI interface plugins from Vojtech Szocs into the Administration Guide.

Email from Vojtech
------------------
Hi Zac,

I'm just writing that I recently updated feature wiki [http://www.ovirt.org/Features/UIPlugins] and wrote entry-level tutorial for plugin developers [http://www.ovirt.org/Tutorial/UIPlugins/CrashCourse].

Feel free to take any changes done in oVirt wiki and reflect them into RHEV Admin Guide. Following link shows the diff (recent changes) for feature wiki:

http://www.ovirt.org/index.php?title=Features%2FUIPlugins&diff=9446&oldid=7830

Regards,
Vojtech


Link to RHEV 3.2 Admin Guide UI Plugin Section
----------------------------------------------
http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.2/html/Administration_Guide/appe-Red_Hat_Enterprise_Virtualization_User_Interface_Plugins.html
Comment 1 Zac Dover 2013-07-28 23:54:13 EDT
# Extract the plugin files to the ui-plugins directory.
tar -C /usr/share/ovirt-engine/ui-plugins -xvf /path/where/downloaded/Space-shooter-ui-plugin-06062013.tar

# Make the files world readable.
chmod -R a+r space-shooter-resources

# Make the *directories* world executable.
find /usr/share/ovirt-engine/ui-plugins/space-shooter-resources -type d -exec chmod a+x {} \;

# If the UI plugins directory does not already exist, create it in
# /etc/ovirt-engine (or wherever ovirt etc files are stored).
mkdir /etc/ovirt-engine/ui-plugins

# Create a local configuration file for the plugin in the new
# /etc/../ui-plugin.  List the domain(s) and IP(s) that
# you plan to use.  The plugin will not work if this configuration lists 
# https://domainA.com and you navigate to that page via https://domainB.com. 
# Remember that the format for non-standard ports is http://domain.com:8000 or
# https://domain.com:8080. For http traffic on port 80 or https on port 443, it is
# not necessary to include a port. The current ovirt documentation shows this 
# file without the surrounding '{}', this is an error. The file must be proper JSON, 
# as it is here.

echo '{"config":{"allowedOrigins": ["https://manager.example.com","https://xx.xx.xx.xx"]}}' > /etc/ovirt-engine/ui-plugins/space-shooter-config.json

# Properly label the new directory and files.
restorecon /etc/ovirt-engine/ui-plugins
restorecon /etc/ovirt-engine/ui-plugins/space-shooter-config.json

# Restart the ovirt-engine. This isn't *always* necessary, but the how and when
# of when you need to and don't is complicated and restarting the engine is easy.
service ovirt-engine restart

# Enjoy your plugin at https://manager.example.com/
# 
# Caveats: 
# * some aspects of plugins don't work in Chrome
# * depending on browser security settings, plugins may not work unless you
#   install the SSL cert for the ovirt engine webadmin
Comment 2 Zac Dover 2013-07-29 00:07:34 EDT
The Space Shooters plugin should not be in the Administration Guide, despite what this bug says. The Space Shooters plugin should be in the Developer Guide, probably in an appendix that explains how to deploy UI Plugins.

The section in the Administration Guide describing the Shell-in-a-Box plugin will be replaced in the Administration Guide with a section describing the GSS UI plugin. The GSS UI Plugin is included in RHEV 3.3 by default (so I am told, though I have not yet confirmed it), so installation instructions will not be necessary in RHEV 3.3 documentation.

It is necessary to write instructions explaining how to install the GSS UI Plugin on RHEV 3.2, however. The section describing the Shell-in-a-Box plugin will be replaced in the RHEV 3.2 documentation with a section describing the GSS UI Plugin. Because the GSS UI Plugin is not installed by default in RHEV 3.2, a section explaining its installation and configuration must be written. This section will be released as a part of the 3.2.z release upcoming in mid-August.
Comment 3 Zac Dover 2013-08-01 21:24:42 EDT
See also:
https://bugzilla.redhat.com/show_bug.cgi?id=965337

RHEV 3.3 Admin Guide will require the "Using Red Hat Support Plugin" topic to be included in its content map.
Comment 4 Zac Dover 2013-08-19 01:17:20 EDT
Documentation Link
------------------
https://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.3/html/Administration_Guide/Using_Red_Hat_Support_Plugin.html

NVR
---
Red_Hat_Enterprise_Virtualization-Administration_Guide-3.3-en-US-3.3-5

What Changed
------------
Previously, "Using Red Hat Support Plugin" was not in the RHEV 3.3 Admin Guide.
Now, "Using Red Hat Support Plugin" is in the RHEV 3.3 Admin Guide.

Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.