Bug 972979 - Java (as, eap, ews) templates should not include a ROOT.war in the template
Java (as, eap, ews) templates should not include a ROOT.war in the template
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On:
Blocks: 1046865
  Show dependency treegraph
 
Reported: 2013-06-10 20:49 EDT by Dan McPherson
Modified: 2015-05-14 19:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1046865 (view as bug list)
Environment:
Last Closed: 2013-06-24 10:53:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan McPherson 2013-06-10 20:49:20 EDT
Description of problem:
The jboss templates are including a ROOT.war in the template downloaded by the user.  This should be a server side component only since it is built when the app is deployed.

To add it to the git repo is bad for a few of reasons:
1) It wastes git space
2) It promotes a bad habit of uploading wars
3) It's confusing.  Implies I need to build my content before I push it.
Comment 2 openshift-github-bot 2013-06-18 15:15:52 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/f96ad24985daab598e5dd937bd21d72680ddf5e3
Bug 972979: Don't include ROOT.war in initial Git repository
Comment 4 Meng Bo 2013-06-19 08:52:43 EDT
Checked on INT(devenv_3382),

For the new created jboss apps, there is no ROOT.war under $OPENSHIFT_JBOSS_DIR

[jbossasapp-domxq1.dev.rhcloud.com 599071435196410961592320]\> ls jbossas/template/deployments/
[jbossasapp-domxq1.dev.rhcloud.com 599071435196410961592320]\> 

For the existing jbossews apps, the symlink under $OPENSHIFT_JBOSS_DIR/webapps is replaced by a real dir

[tomcat-bmeng1int.int.rhcloud.com 51ba916e6cec0e28b3000027]\> ls -l jbossews/|grep web
drwxr-xr-x. 2 51ba916e6cec0e28b3000027 51ba916e6cec0e28b3000027 4096 Jun 18 23:39 webapps


Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.