Bug 973010 - Warn of the hazards of running services on RHEV nodes
Warn of the hazards of running services on RHEV nodes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Zac Dover
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 00:37 EDT by Zac Dover
Modified: 2015-09-22 09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-16 10:18:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zac Dover 2013-06-11 00:37:54 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=903941

BZ#903941 asks for a note to be included in the RHEV documentation warning that if DNS is run from within a RHEV node, the services provided by that DNS will no longer be provided if the node ceases to function.

This is a specific instance of a general case. The general case is that any service run from within a RHEV node will cease to function if the RHEV node ceases to function.

It seems wise to include a note about this in the RHEV documentation. Including such a note informs customers of these hazards and diminishes liability for RH.

Because the general case includes the specific instance, I have closed the bug that refers to the specific instance.


What Does This Bug Ask For
---------------------------
A note in the RHEV Documentation Suite warning of the dangers of running services inside RHEV nodes.
Comment 1 Zac Dover 2013-06-11 00:45:54 EDT
Topic 8759 (Admin Guide, "Introduction to Logical Networks") updated with a warning against running services inside RHEV nodes.
Comment 2 Zac Dover 2013-06-11 00:46:50 EDT
Topic 8668 (Installation Guide, "Networking in Red Hat Enterprise Virtualization") updated with a warning against running services inside RHEV nodes.
Comment 3 Zac Dover 2013-06-11 05:55:08 EDT
I have added this information to the Administration and Installation Guides.


RHEV Administration Guide 3.2
-----------------------------
http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.2/html-single/Administration_Guide/index.html#Logical_networks

RHEV Installation Guide 3.2
---------------------------
http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Enterprise_Virtualization/3.2/html-single/Installation_Guide/index.html#Determine_Network_Requirements

NVR
---
Red_Hat_Enterprise_Virtualization-Administration_Guide-3.2-en-US-3.2-39
Red_Hat_Enterprise_Virtualization-Installation_Guide-3.2-en-US-3.2-13

What Changed
------------
The following was added to
  * Admin Guide: Section 5.1 "Introduction to Logical Networks"
  * Install Guide: Section 11.2 "Networking in Red Hat Enterprise Virtualization"

If you plan to use Red Hat Enterprise Virtualization nodes to provide any services, remember that the services will stop if the Red Hat Enterprise Virtualization environment stops operating.
This applies to all services, but you should be especially aware of the hazards of running the following on Red Hat Enterprise Virtualization:

    Directory Services
    DNS
    Storage 




Moving to ON_QA.
Comment 5 Zac Dover 2014-03-11 22:49:00 EDT
This was already verified. I can't imagine why I changed it last June.

Note You need to log in before you can comment on or make changes to this bug.