Bug 973040 - Spring start failed
Spring start failed
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 03:01 EDT by Michael Egberts
Modified: 2015-05-14 22:23 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 09:19:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Egberts 2013-06-11 03:01:34 EDT
Description of problem:
Spring cartridge setup failed

> Version-Release number of selected component (if applicable):
The current cartridge in the overview of possible applications

> How reproducible:
Initial setup showed error screen because of existing application name (allthough in this namespace this doesn't exist) 
After refresh a new application name has been entered which resulted in an error again 
Currently refreshes result in error so no changes can be made or the specific application can not be removed 

> Steps to Reproduce:
1.Create spring cartridge with name spring
2.After errror refresh and enter different name
3.Currently application cannot be used or changed

> Actual results:
Error

> Expected results:
Edit application to remove application and try again

> Additional info:
Comment 1 Dan McPherson 2013-06-11 10:10:28 EDT
Hi Michael,

  Can you provide more detailed steps as to the commands you ran and possibly the cartridge you used?

-Dan
Comment 2 Michael Egberts 2013-06-13 03:32:36 EDT
Hi Dan,

I clicked "add application"

Selected spring (the current version)

Entered the name "spring" (namespace was already filled) 

And after continue the error occured

Refreshing the screen (as suggested) showed me the application name screen again after which i changed this to springtest (again namespace was still filled)

When I pressed continue it failed permanently and refresh failed permanently too...

This is actually all I did for now
Doest this clarify?
Comment 3 Dan McPherson 2013-07-23 11:43:15 EDT
Hi Michael,

  When it fails, what's the error message?  Is there a reference id?

  Also have you tried the client tools (rhc) to delete the app?

  We made a change with the last release that fixed an issue creating a spring app.  But I need more details about your error if it is wedged in some way that you aren't able to clean up.

-Dan
Comment 4 Michael Egberts 2013-07-29 03:46:05 EDT
Hi Dan,

Sorry for the late reply, it is holiday season over here ;-)

Consider this bug closed.
When I logged in this seemed to be solved already.

Great work,
Thanks!

Note You need to log in before you can comment on or make changes to this bug.