Bug 973091 - [RHS-C] Binary hook contents are being displayed during Resolve Conflicts
[RHS-C] Binary hook contents are being displayed during Resolve Conflicts
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Kanagaraj
Prasanth
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 05:27 EDT by Prasanth
Modified: 2016-04-18 06:06 EDT (History)
12 users (show)

See Also:
Fixed In Version: CB10
Doc Type: Bug Fix
Doc Text:
Previously, binary hook contents were displayed during Resolve Conflicts. Now, with this update, the binary hook content is not displayed in the 'Resolve Conflicts' window.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:30:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error (57.43 KB, image/png)
2013-06-11 05:27 EDT, Prasanth
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15704 None None None Never
oVirt gerrit 15708 None None None Never
oVirt gerrit 21710 None None None Never

  None (edit)
Description Prasanth 2013-06-11 05:27:39 EDT
Created attachment 759503 [details]
screenshot of error

Description of problem:

Binary hook contents are being displayed during Resolve Conflicts

Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb2.el6rhs 


How reproducible: Always


Steps to Reproduce:

Create a 3 server cluster.

1. Create a Text Hook (say: testhook.sh) in one of the servers and sync it across all the servers using the Resolve Conflict Missing feature.
2. Copy a Binary Hook to server1 with the same name as that of the Text Hook (testhook.sh). So currently, Server1 is having a binary hook with the name testhook.sh; server2 and server3 are having a text hook with the same name (testhook.sh)
3. A content conflict will now be determined in the UI and click on "Resolve Conflicts". The server copy will still be showing the "Text" content of the hook, whereas, server1 will be showing the "Binary" content.


Actual results: Binary contents of a hook is being displayed


Expected results: Content of the hook can be viewed ONLY if the hook content type is 'Text' as per http://www.ovirt.org/Features/Gluster_Hooks_Management#User_work-flows

Additional info: Screenshot attached.
Comment 2 Prasanth 2013-07-09 03:32:07 EDT
>> 3. A content conflict will now be determined in the UI and click on "Resolve Conflicts". The server copy will still be showing the "Text" content of the hook, whereas, server1 will be showing the "Binary" content.

Now the Binary content is not getting displayed in server1, but instead it shows the text content with a different md5sum when we change the "Source" from "Engine (Master)" to "server1". May be the cleanup is not happening properly during the Source switch.

Moving back to Assigned.
Comment 3 Dustin Tsang 2013-12-04 13:25:03 EST
verified in rhsc-cb10
Comment 4 Shalaka 2014-01-07 02:03:38 EST
Please review the edited DocText and signoff.
Comment 5 Kanagaraj 2014-01-16 01:59:48 EST
doc_text looks good.
Comment 7 errata-xmlrpc 2014-02-25 02:30:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.