Bug 9731 - Kickstart + CD-ROM install broken
Kickstart + CD-ROM install broken
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-23 20:48 EST by bentlema
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-21 07:25:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bentlema 2000-02-23 20:48:59 EST
I've tried both the "boot" image and "bootnet" image using "linux ks" to
boot.

Using the "boot" image, the installer bombs out with the following python
error:

      Traceback (innermost last):
        File "/usr/bin/anaconda", line 30, in ?
          [ 'gui', 'text', 'test', 'debug', 'method=', 'rootpath='
        File "/usr/lib/python1.5/sit-packages/isys.py", line 135 in getopt
          return apply(_isys.getopt, args)
      TypeError: bad argument --kickstart: missing argument

The "boot" image assumes you'll be installing off CD-ROM without kickstart.
It doesn't know how to handle kickstart mode.  So we tried the "bootnet"
image.

Using the "bootnet" image, the installer broadcasts for its network config
via BOOTP/DHCP, mounts up the filesystem with the kickstart config file,
reads it, but then compalins:  "no install method specified for kickstart".

I'm specifying the "cdrom" install method, but the installer doesn't seem
to know how to handle it.  This combination of using Kickstart to get the
network config, but installing off CD-ROM used to work, and was extremely
useful for us here at the CS&E department for installing entire labs at a
time.

Kickstart + the nfs install method does work, but we can only install a
couple machines at a time, otherwise we saturate the network.  It's much
nicer to be able to go into the lab, load CD-ROMs of RedHat into 40 or so
machines, boot off CD-ROM (fast), linux ks, and come back 10 minutes, and
the whole lab is done.

It would be greately appreciated if this functionality could be returned.
Thanks!

--Mark
Comment 1 Jay Turner 2000-02-24 11:05:59 EST
The modules for network cards are not in the local boot image, and that is why
you are seeing the python excpetion.  The machine is not able to retrieve the
ks.cfg file from the network because the network is not up.

A couple of suggestions.  1) create your own custom CDROM which has the
bootnet.img in the bootsector and would then boot the image which has the NIC
modules  2) boot from a floppy with the ks.cfg file  3) install one machine and
then use it as a NFS server for the remainder of the machines.
Comment 2 bentlema 2000-02-24 11:43:59 EST
If you'd take the time to read my above comments, you'd see that I *DID* use the
bootnet image.   (I tested *BOTH* boot and bootnet.)

The "bootnet" image is broken.  The install reads the kickstart file just fine,
but it doesn't know what to do with the "cdrom" install method.  The install
responds with "no install method specified for kickstart".

My theory:  the installer on the bootnet disk only knows how to do NFS, FTP, or
HTTP installs.

Your 1st suggestions of creating our own CDROM is exactly what we do.  It would
work great if the bootnet image worked.

Your 2nd suggestion of using a floppy with the ks.cfg file is not an option for
us.  We have over 200 RedHat machines which we maintain.  Having a floppy for
each machine is out of the question.  This is why we store our configs remotely.

Your third suggestion doesn't make sence.  We already have local NFS server with
the RedHat distributions, and it has interfaces on all of our networks.  The
problem is network bandwidth.  Even 100Mbit ethernet is easy to saturate.
Comment 3 Jay Turner 2000-02-25 07:07:59 EST
Yes, looking back at the code, I do see that it is not possible to perform a
CDROM installation after booting from the network boot disk.  So, basically one
of the ideas that I gave is not valid.  The bootnet.img disk can only be used to
perform a network installation, and the boot.img disk can only be used to
perform a local installation.

I will add this request to a features list for future releases.
Comment 4 Brock Organ 2000-04-17 14:39:59 EDT
taking only one small part of your report...

	The "boot" image assumes you'll be installing off
	CD-ROM without kickstart.  It doesn't know how to
	handle kickstart mode.

I did verify that the 6.2 boot.img does support kickstart using a cdrom ... does
this help with your problem...?
Comment 5 bentlema 2000-04-20 14:24:59 EDT
Unfortunately not.  The boot.img may partially support kickstart using a cdrom,
but it doesn't appear to work in my case.  How did you get it to work?

It's not even getting to the point where it tries to configure it's network
interface via DHCP and read the kickstart config file via NFS.

I'm doing a "linux ks" at the SYSLINUX prompt, things work up to a certain
point, the installer does mount up the cdrom and start to load device driver
modules (such as the ethernet driver), but then bombs out with the following
error:

      Traceback (innermost last):
         File "/usr/bin/anaconda", line 45, in ?
           [ 'gui', 'text', 'reconfig', 'test', 'debug',
         File "/usr/lib/anaconda/isys.py", line 198 in getopt
           return apply(_isys.getopt, args)
       TypeError: bad argument --kickstart: missing argument

I've dried both the shipped boot.img and the boot-20000407.img, and both give
the same results.

I've also tried using the bootnet.img and bootnet-20000407.img, and both of
these work up to the point where the installer is trying to decided where to get
the distribution from. Instead of using "nfs" I've specified "cdrom", but the
installer gives the error "no install method specified for kickstart".
Comment 6 Jay Turner 2000-04-21 07:25:59 EDT
This is not a supported configuration.  If you are booting from the CDROM, then
you are essentially booting using the boot.img file, which has no concept of
network support.  This split of boot disk was due to lack of disk space (on a
1.44M floppy) for inclusion of the variety of modules that were needed for each
installation method.

The only way that you are going to be able to use a CDROM to initiate a
kickstart installation where the ks.cfg file is retrieved from a NFS server is
if you create your own CDROM which has the bootnet.img file in the bootsector as
opposed to the boot.img file which is there by default.  This can easily be done
using mkisofs, and there are a number of documents on the web about this very
thing.

Note You need to log in before you can comment on or make changes to this bug.