Bug 973135 - JPP6.0 Backward compatibility - unable to log in with an old account
JPP6.0 Backward compatibility - unable to log in with an old account
Status: CLOSED NOTABUG
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER02
: 6.1.0
Assigned To: Lucas Ponce
vramik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 06:58 EDT by vramik
Modified: 2013-11-04 19:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 03:13:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vramik 2013-06-11 06:58:57 EDT
Description of problem:
JPP6.0 Backward compatibility - unable to log in with an account from JPP6.0

Version-Release number of selected component (if applicable):
JPP6.1.ER01

How reproducible:
always

Steps to Reproduce:
1. start and stop JPP6.0 
2. copy $JPP60/standalone/data/gatein to $JPP61/standalone/data
3. edit $JPP61/gatein/gatein.ear/portal.war/WEB-INF/conf/organization/picketlink-idm/picketlink-idm-config.xml according to https://docs.jboss.org/author/display/GTNPORTAL36/Password+Encryption#PasswordEncryption-HashingEncoder :

<option>
  <name>credentialEncoder.class</name>
  <value>org.picketlink.idm.impl.credential.HashingEncoder</value>
</option>
<option>
  <name>credentialEncoder.hashAlgorithm</name>
  <value>MD5</value>
</option>

4. start JPP6.1 and open http://$HOST:8080/portal
5. there is Set root password dialog

Actual results:
Set root password dialog

Expected results:
default page with possibility to log in

Additional info:
When I set root password I tried to log in as John and login failed. There all default users in Users and groups management.
Comment 1 Lucas Ponce 2013-06-11 12:01:55 EDT
Hello,

It looks like that test's steps are not correct.
Copying full data/gatein (step 2) means to overwrite the JCR configuration.

I've performed the following steps to validate that we can easily import users from JPP6.0 to JPP6.1.

1.- Start JPP6.0.
2.- Create a new user in JPP6.0 (i.e. testuser/password).
3.- Stop JPP6.0.
4.- Unzip a fresh install of JPP61 ER01.1.
5.- Set up credentialEncoder as JPP6.0:

$JPP61/gatein/gatein.ear/portal.war/WEB-INF/conf/organization/picketlink-idm/picketlink-idm-config.xml

<option>
  <name>credentialEncoder.class</name>
  <value>org.picketlink.idm.impl.credential.HashingEncoder</value>
</option>
<option>
  <name>credentialEncoder.hashAlgorithm</name>
  <value>MD5</value>
</option>

6.- Start JPP6.1.
7.- Configure root user (this will set up a JCR flag).
8.- Stop JPP6.1.
9.- Copy IDM database from JPP6.0 to JPP6.1.
    $(JPP60)/standalone/data/gatein/portal/jdbcidm_portal.h2.db into
    $(JPP61)/standalone/data/gatein/portal/
10.- Start JPP6.1
11.- Validate that you can enter with your users of JPP6.0:
     testuser/password
     root/gtn (instead of root user in the setup).

Please, could you repeat this test to validate it.

Thanks,
Lucas Ponce
Comment 2 vramik 2013-06-11 18:39:00 EDT
Hi,

I've followed steps from Lucas's comment and I can confirm it works as described in the comment. 

In my opinion this step should be definitely described in migration guide. 

Thank you Lucas for your comment.

Vlasta
Comment 3 Lucas Ponce 2013-06-12 03:13:41 EDT
Thanks Vlasta for your tests.

I'm going to close the BZ and contact with team to place a note for documentation.

Lucas
Comment 4 Lucas Ponce 2013-06-12 05:32:07 EDT
I've tested also the same scenario but changing H2 by MySQL and it works without issues.

So, we will update the doc to explain the process.

Thanks,
Lucas
Comment 5 Lucas Ponce 2013-06-12 05:39:30 EDT
An additional note:

- The only additional note is that migrating users from JPP 6.0 to JPP 6.1 only requeries to update root user password.
- JPP 6.1 has a JCR flag (that are not present in JPP 6.0) to detect if this is a new installation, and then set up the root password.
- We are discussing if this is valid or if this logic have to be change thinking on migration (the only impact is to re-set the root password, rest of user remains as in JPP 6.0).
Comment 6 Lucas Ponce 2013-06-13 12:27:56 EDT
Note added on:

https://docs.jboss.org/author/display/EPP61/Migration+notes+source+info

So, as a summary, JPP 6.1 is fully compatible with JPP 6.0 migrating users and portal structure.

We have made tests with H2 and MySQL databases.

It's part of the process, that in the first installation of JPP 6.1, password of root user has to be updated.

Please, let us know if there is some issue or something is not working as described.

Thanks,
Lucas

Note You need to log in before you can comment on or make changes to this bug.