Bug 973136 - JBPM Business Central doesn't log any messages or errors in console
JBPM Business Central doesn't log any messages or errors in console
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: DR6
: 6.0.0
Assigned To: Kris Verlaenen
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 07:05 EDT by Ivo Bek
Modified: 2014-08-06 16:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-06-11 07:05:02 EDT
Description of problem:

Because I went through some sources for REST API (e.g. https://github.com/droolsjbpm/kie-wb-common/blob/master/kie-wb-common-services/kie-wb-common-rest/src/main/java/org/kie/workbench/common/services/rest/ProjectResource.java) where are system outs and deeper are loggers with info and errors, I didn't notice about anything what should be logged in console and even errors weren't logged.

To fix it I had to remove log4j.xml from WEB-INF and probably it would be better to use the log4j jar from module (<module name="org.apache.log4j" />) loaded by jboss-deployment-structure.xml.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Kris Verlaenen 2013-06-27 08:24:26 EDT
Fixed in Beta4
Comment 3 Ivo Bek 2013-07-11 04:28:19 EDT
Verified in JBoss BPMS 6.0.0.DR6

Note You need to log in before you can comment on or make changes to this bug.