Bug 973137 - [RHS-C] Error while executing action: Cannot edit Gluster Hook. There are no conflicting servers to add or update hook
[RHS-C] Error while executing action: Cannot edit Gluster Hook. There are no ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Sahina Bose
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 07:08 EDT by Prasanth
Modified: 2013-09-23 18:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: bb4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error (146.71 KB, image/png)
2013-06-11 07:08 EDT, Prasanth
no flags Details
engine log (3.79 MB, text/x-log)
2013-06-11 07:14 EDT, Prasanth
no flags Details
vdsm log (6.94 MB, text/x-log)
2013-06-11 07:16 EDT, Prasanth
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15717 None None None Never

  None (edit)
Description Prasanth 2013-06-11 07:08:25 EDT
Created attachment 759562 [details]
screenshot of error

Description of problem:

"Error while executing action: Cannot edit Gluster Hook. There are no conflicting servers to add or update hook"

Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb2.el6rhs 


How reproducible: Most of the time


Steps to Reproduce:
Create a 3 server cluster.

1. Create a Text Hook (say: S34testhook.sh) in one of the servers and sync it across all the servers using the Resolve Conflict Missing feature.

2. Copy a Binary Hook to server1 with the same name as that of the Text Hook (S34testhook.sh). So currently, Server1 is having a binary hook with the name S34testhook.sh; server2 and server3 are having a text hook with the same name (S34testhook.sh)

3. A content conflict will now be determined in the UI and is supposed to be between the Engine and the 3 servers.

4. Now click on "Resolve Conflicts", select "Use content from: server1" and click on OK.


Actual results: 

a.) First time on clicking Ok, we won't see any error and the message "Gluster Hook 30samba-set.sh updated on conflicting servers." is seen in Events. However, it didn't actually resolve the content conflict as the file is still different (Text Hook) in server2 and server3 and the exclamation (!) mark is still present for the hook. I've confirmed the same from the back-end
  
   This should have actually copied the hook from server1 to Engine, server1 and server3 which didn't happen and hence this is the first stage of bug.

b.) If we try to resolve the hook for the second time, by selecting any of the server as "Use content from:", following error is seen:

"Error while executing action: Cannot edit Gluster Hook. There are no conflicting servers to add or update hook."


Expected results: Resolve conflict should work fine.


Additional info: Logs and screenshot attached
Comment 1 Prasanth 2013-06-11 07:14:45 EDT
Created attachment 759563 [details]
engine log
Comment 2 Prasanth 2013-06-11 07:16:55 EDT
Created attachment 759569 [details]
vdsm log
Comment 4 Prasanth 2013-06-28 04:18:53 EDT
Verified as fixed in bb4
Comment 5 Scott Haines 2013-09-23 18:25:47 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.