Bug 973149 - for snapshot based volumes, size should be enforced to be at least on par with the snapshot size
for snapshot based volumes, size should be enforced to be at least on par wit...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
low Severity low
: Upstream M1
: 4.0
Assigned To: Eric Harney
Yogev Rabl
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 07:28 EDT by Giulio Fidente
Modified: 2016-04-26 20:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-0.4.b2.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, the Block Storage service incorrectly allowed users to attempt cloning a snapshot into a smaller volume. The attempt only failed when the volume filled up as expected during the volume creation process. With this fix, the Block Storage service will now check the volume size argument whenever users attempt to clone a snapshot. As a result, the Block Storage service will automatically fail any attempts to clone a snapshot into a smaller volume before even initiating the clone.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:05:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1161841 None None None Never
Launchpad 1189779 None None None Never
OpenStack gerrit 25783 None None None Never
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-20 19:01:48 EST

  None (edit)
Description Giulio Fidente 2013-06-11 07:28:27 EDT
Description of problem:
when creating a snapshot based volume, it is currently permitted to pass as size argument a value smaller than the actual snapshot size

the volume creation terminates with an error as soon as the backing volume is filled

the API could get smarter and enforce the user to use as size a value greater or identical to the snapshot size


Version-Release number of selected component (if applicable):
openstack-cinder-2013.1.1-4.el6ost.noarch


Steps to Reproduce:
1. create a 2g volume (vol1)
2. create a snap of vol1 (snap1)
3. create a 1g volume from snap1 (vol2)


Actual results:
creation starts and reports failure when the backing LV is full


Expected results:
API returns error and doesn't initiate the operation
Comment 1 Eric Harney 2013-06-11 08:23:04 EDT
It's not clear to me that this is severe enough to be worth backporting.
Comment 5 Giulio Fidente 2013-10-10 11:06:43 EDT
verified using openstack-cinder-2013.2-0.9.b3.el6ost
Comment 8 errata-xmlrpc 2013-12-19 19:05:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.