Bug 973172 - Need error handling and message for repo sync with a bad feed
Need error handling and message for repo sync with a bad feed
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.2 Beta
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 08:16 EDT by Preethi Thomas
Modified: 2015-02-28 16:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:56:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 355 None None None Never

  None (edit)
Description Preethi Thomas 2013-06-11 08:16:09 EDT
Description of problem:

Repo sync fails with no error message when syncing repos with a bad feed url.

Version-Release number of selected component (if applicable):

[root@hp-dl360g6-01 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.2.beta.fc18.noarch

How reproducible:


Steps to Reproduce:
1.create a repo with bad feed 
2.Sync the repo
3.

Actual results:
[root@hp-dl360g6-01 ~]# pulp-admin iso repo create --repo-id "ABC" --feed test
Successfully created repository [ABC]

[root@hp-dl360g6-01 ~]# pulp-admin rpm repo create --repo-id "ABCD" --feed test
Successfully created repository [ABCD]

[root@hp-dl360g6-01 ~]# pulp-admin rpm repo sync run --repo-id "ABCD" 
+----------------------------------------------------------------------+
                    Synchronizing Repository [ABCD]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[-]
[root@hp-dl360g6-01 ~]# pulp-admin iso repo sync run --repo-id "ABCD" 
+----------------------------------------------------------------------+
                    Synchronizing Repository [ABCD]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.



Expected results:


Additional info:
Comment 1 Michael Hrivnak 2013-07-05 15:45:09 EDT
It looks like this has been fixed for both iso and rpm syncs.
Comment 2 Jeff Ortel 2013-09-12 18:35:55 EDT
build: 2.3.0-0.10.alpha
Comment 3 Preethi Thomas 2013-09-19 16:22:48 EDT
failing, iso repo sync with bad feed's output should be consistent with rpm

[root@pulp-v2-server ~]# pulp-admin iso repo create --repo-id "ABC" --feed test
Successfully created repository [ABC]

[root@pulp-v2-server ~]#  pulp-admin rpm repo create --repo-id "ABCD" --feed test
Successfully created repository [ABCD]

[root@pulp-v2-server ~]# pulp-admin rpm repo sync run --repo-id "ABCD" 
+----------------------------------------------------------------------+
                    Synchronizing Repository [ABCD]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[-]
... failed

Unsupported scheme: 

[root@pulp-v2-server ~]# pulp-admin iso repo sync run --repo-id "ABC"
+----------------------------------------------------------------------+
                     Synchronizing Repository [ABC]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading the Pulp Manifest failed:

	{u'response_code': 0, u'error_message': u"Couldn't resolve host 'test'",
u'error_code': 6}

[root@pulp-v2-server ~]#
Comment 4 Chris Duryee 2014-11-11 17:08:30 EST
These still have different outputs as of pulp 2.4.3

$ pulp-admin rpm repo sync run --repo-id "ABCD" 
+----------------------------------------------------------------------+
                    Synchronizing Repository [ABCD]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


Downloading metadata...
[-]
... failed

Unsupported scheme: 


Task Failed

Importer indicated a failed response



$ pulp-admin iso repo sync run --repo-id "ABC" 
+----------------------------------------------------------------------+
                     Synchronizing Repository [ABC]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


Downloading the Pulp Manifest failed:

        {}


Task Failed

Importer indicated a failed response
Comment 5 Brian Bouterse 2015-02-28 16:56:47 EST
Moved to https://pulp.plan.io/issues/355

Note You need to log in before you can comment on or make changes to this bug.