Bug 973232 - ticketmonster-cordova (2.3.0.ER1) does not compile in XCode
ticketmonster-cordova (2.3.0.ER1) does not compile in XCode
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TicketMonster (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity high
: CR1
: 2.3.0
Assigned To: Vineet Reynolds
Tomas Repel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 09:56 EDT by Tolis Emmanouilidis
Modified: 2014-03-03 19:27 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:00:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JDF-370 Major Resolved ticket-monster cordova ios build fails in XCode due to missing CordovaLib classes 2013-07-16 06:56:47 EDT

  None (edit)
Description Tolis Emmanouilidis 2013-06-11 09:56:39 EDT
Description of problem:
The ticketmonster-cordova is iOS does not compile. Basically some classes are missing from the included CordovaLib.

Version-Release number of selected component (if applicable):
2.3.0.ER1

How reproducible:
Open the ticketmonster-cordova xcode project in xcode and try to compile it.

Steps to Reproduce:
1. Open the ticketmonster-cordova xcode project in Xcode
2. Compile it

Actual results:
CordovaLib/Classes/CDVCamera.h: No such file or directory
CordovaLib/Classes/CDVExif.h: No such file or directory
CordovaLib/Classes/CDVFile.h: No such file or directory
CordovaLib/Classes/NSDictionary+Extensions.h: No such file or directory

There are more classes missing.

Expected results:
Success compilation.

Additional info:
I copied the CordovaLib folder from the kitchensink-cordova example included inside the Quickstarts 2.3.0.ER1 and the ticketmonster compiled successfully.
Comment 1 JBoss JIRA Server 2013-06-13 09:46:10 EDT
Vineet Reynolds <vineet.reynolds@gmail.com> updated the status of jira JDF-370 to Resolved
Comment 2 JBoss JIRA Server 2013-06-13 09:46:10 EDT
Vineet Reynolds <vineet.reynolds@gmail.com> made a comment on jira JDF-370

Pushed upstream https://github.com/jboss-jdf/ticket-monster/commit/d41a7ad4b345d037e46695c6329e8f1740848a80

Note You need to log in before you can comment on or make changes to this bug.