Bug 97325 - mount succeeds but command does not complete
mount succeeds but command does not complete
Status: CLOSED DUPLICATE of bug 90036
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-12 20:59 EDT by Brett Porter
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brett Porter 2003-06-12 20:59:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030508

Description of problem:
I have a filesystem mounted like so in fstab:
//gollum/mp3            /mnt/gollum             smbfs  
credentials=/home/bporter/.samba.credentials,gid=500,uid=500,ro  0 0
(and some that are not "ro").

I have several such mounts, and this occurs only for some and not consistently.
The target machines are Win2k, Linux and Solaris with varying samba version. The
solaris machine seems not to be affected.

Since upgrading to RHL 9, sometimes the mount command for one of these will
appear to hang, but hitting ctrl-C ends it and shows that the mount succeeded.
However, this has meant that I have to use noauto so that bootup succeeds, and
then mount each individually.

There are no problems with umount.

I can't get two mounted in succession, but sometimes it is the first that fails,
sometimes the second, then the next may work or not, and so on.

Version-Release number of selected component (if applicable):
samba-2.2.7a-8.9.0

How reproducible:
Always

Steps to Reproduce:
mount /mnt/gollum
(hangs, so Ctrl-C)
mount

shows:
...
//gollum/mp3 on /mnt/gollum type smbfs (0)
Comment 1 Jay Fenlason 2003-06-13 15:14:16 EDT

*** This bug has been marked as a duplicate of 90036 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.