Bug 973251 - Requesting build of libbsd for EL5
Requesting build of libbsd for EL5
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: libbsd (Show other bugs)
el5
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Eric Smith
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 10:45 EDT by Steve Jenkins
Modified: 2013-06-28 14:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: libbsd-0.5.2-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 14:50:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Jenkins 2013-06-11 10:45:01 EDT
This purpose of this report is to request building libbsd for EL5.

I have contacted Eric Smith (the current maintainer) who builds it for Fedora and EL6, and he requested that I file this enhancement request.

Initial problem is that a mock build of the current spec file against EL5 reports:

DEBUG util.py:264:  error: unpacking of archive failed on file /builddir/build/SOURCES/libbsd-0.5.2.tar.xz;51b6bd17: cpio: MD5 sum mismatch

See full root log here (thanks, Eric):

http://kojipkgs.fedoraproject.org/work/tasks/9621/5489621/root.log

I am able to manually build from source on an EL5 box with a simple ./configure, make, make install.

Is it possible that this bug is what's contributing to the build issue, and that one of the workarounds in the comments will address it?

https://bugzilla.redhat.com/show_bug.cgi?id=490613
Comment 1 Susi Lehtola 2013-06-11 10:49:45 EDT
(In reply to Steve Jenkins from comment #0)
> Initial problem is that a mock build of the current spec file against EL5
> reports:
> 
> DEBUG util.py:264:  error: unpacking of archive failed on file
> /builddir/build/SOURCES/libbsd-0.5.2.tar.xz;51b6bd17: cpio: MD5 sum mismatch

(clip)
 
> Is it possible that this bug is what's contributing to the build issue, and
> that one of the workarounds in the comments will address it?
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=490613

Note that this doesn't pose any problems for an EL5 branch. The fedora build system doesn't use prebuilt srpms; instead it builds the srpm from the spec file and the sources at the start of the build process.
Comment 2 Steve Jenkins 2013-06-11 11:15:32 EDT
I cloned libbsd and tried a scratch build with the dist-5E-epel target and everything seems OK except for some issues with arch ppc:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5492259
Comment 3 Eric Smith 2013-06-11 11:55:22 EDT
I don't think #490613 is at issue, since we're not trying to install a Fedora SRPM as part of the process.

It appears that your scratch build failed on PPC and killed the i386 and x86_64 builds before they got to the point of trying to decompress the .tar.xz in the setup macro.  Presumably this would happen if the PPC builder was less busy than the i386 and x86_64 builders.  However, the PPC builder decompressed the .tar.xz just fine, and there's no obvious reason why that should succeed when i386 and x86_64 fail.

I'll try the workaround given in bug 620674, explicitly piping xzcat into tar.  If that solves it, I'll file a bug against rpm in EL5, though I doubt that the powers that be will decide to fix it.

The PPC build problem is in the install section, failing to do a variable substitution of %{buildroot}.  Since the i386 and x86_64 builds didn't even get that far, it's possible that this is due to an EL5 difference rather than being anything specific to PPC.
Comment 4 Susi Lehtola 2013-06-11 12:30:03 EDT
(In reply to Eric Smith from comment #3)
> The PPC build problem is in the install section, failing to do a variable
> substitution of %{buildroot}.  Since the i386 and x86_64 builds didn't even
> get that far, it's possible that this is due to an EL5 difference rather
> than being anything specific to PPC.

Sounds like you are missing the BuildRoot field from the spec file.

Be sure to put in all of the other necessary stuff as well, i.e.
* rm -rf %{buildroot} in  %clean and at the start %install
* %defattr(-,root,root) in all %files sections
and so on. Remember to check the result RPM with rpmlint.
Comment 5 Eric Smith 2013-06-11 15:58:39 EDT
You're right!  I'd forgotten about all the otherwise obsolete stuff that has to be done for EL5, since I hadn't thought that I'd be maintaining any EL5 packages.  Thanks!  I'll put that stuff in and try again.
Comment 6 Fedora Update System 2013-06-12 13:55:05 EDT
libbsd-0.5.2-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/libbsd-0.5.2-2.el5
Comment 7 Fedora Update System 2013-06-12 16:09:08 EDT
libbsd-0.5.2-2.el5 has been pushed to the Fedora EPEL 5 testing repository.
Comment 8 Steve Jenkins 2013-06-12 17:25:55 EDT
Excellent! I'll test it out.
Comment 9 Fedora Update System 2013-06-28 14:50:03 EDT
libbsd-0.5.2-2.el5 has been pushed to the Fedora EPEL 5 stable repository.

Note You need to log in before you can comment on or make changes to this bug.