Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 973255 - spacewalk-splice-checkin default config missing logging section causes a traceback
spacewalk-splice-checkin default config missing logging section causes a trac...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: James Slagle
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-06-11 10:50 EDT by mkovacik
Modified: 2013-10-01 06:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:56:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1390 normal SHIPPED_LIVE Release 1.3 of Subscription Asset Manager 2013-10-01 10:43:14 EDT

  None (edit)
Description mkovacik 2013-06-11 10:50:20 EDT
Description of problem:

Logging section missing in  /etc/splice/checkin.conf causes a stack trace in spacewalk-splice-checkin. 

Version-Release number of selected component (if applicable):
SAM-1.3-RHEL-6-20130606.n.1-SAM-x86_64-dvd1.iso

How reproducible:
Always

Steps to Reproduce:
1. remove logging entry from /etc/splice/checkin.conf (or just install splice tools --- the default checkin.conf doesn't contain logging entry)
2. run /usr/bin/spacewalk-splice-checkin --splice-sync


Actual results:
Missing logging entry in /etc/splice/checkin.conf prevents spacewalk-splice-checkin from running

Expected results:
missing logging entry handled by default settings

Additional info:

Traceback (most recent call last):
  File "/usr/bin/spacewalk-splice-checkin", line 51, in <module>
    init_logging()
  File "/usr/bin/spacewalk-splice-checkin", line 29, in init_logging
    log_config = CONFIG.get("logging", "config")
  File "/usr/lib64/python2.6/ConfigParser.py", line 532, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'logging'
Comment 1 James Slagle 2013-06-19 08:11:25 EDT
Defaults for all of the config values for spacewalk-splice-tool are not hard coded, and I don't think they need to be.  This file will always exist due to packaging.

The file is provided by splice-common-config, which is required by splice-common, which is required by spacewalk-splice-tool:

[root@rhel-sst ~]# rpm -qf /etc/splice/logging/basic.cfg 
splice-common-config-0.126-1.git.2.4fbb00a.el6.noarch
[root@rhel-sst ~]# rpm -q --requires spacewalk-splice-tool | grep splice
config(spacewalk-splice-tool) = 0.20-1.el6sam
splice-common >= 0.77
[root@rhel-sst ~]# rpm -q --requires splice-common | grep splice
config(splice-common) = 0.126-1.git.2.4fbb00a.el6
splice-common-config = 0.126-1.git.2.4fbb00a.el6
Comment 2 John Matthews 2013-06-21 07:10:57 EDT
Should this be moved to CLOSED NOTABUG?
Comment 3 James Slagle 2013-06-21 07:18:08 EDT
i'll move to ON_QA.  not sure how sst was installed without this file, so maybe the deps were wrong before.  it needs to be verified that installing sst also (indirectly) creates /etc/splice/logging/basic.cfg
Comment 4 Vitaly Kuznetsov 2013-06-21 09:00:11 EDT
The packaging is ok:
[root@ec2-46-137-24-190 ~]# rpm -qf /etc/splice/logging/basic.cfg 
splice-common-config-0.130-1.el6sam.noarch
[root@ec2-46-137-24-190 ~]# rpm -q --requires spacewalk-splice-tool | grep splice
config(spacewalk-splice-tool) = 0.24-1.el6sam
splice-common >= 0.77
[root@ec2-46-137-24-190 ~]# rpm -q --requires splice-common | grep splice
config(splice-common) = 0.130-1.el6sam
splice-common-config = 0.130-1.el6sam
Comment 6 errata-xmlrpc 2013-10-01 06:56:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.