Bug 973264 - Star import does not work with DRL declared facts
Star import does not work with DRL declared facts
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER2
: 6.0.0
Assigned To: Mario Fusco
Marek Winkler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 11:01 EDT by Marek Winkler
Modified: 2014-08-06 16:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:17:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Winkler 2013-06-11 11:01:28 EDT
Description of problem:

Given the following DRL:

package org.drools.compiler.integrationtests

import org.drools.compiler.integrationtests.facts.*

declare TestEvent
    @role(event)
end

rule "SendEvent"
	when
		$event : TestEvent()
	then
        // rule fired
end

When an instance of TestEvent is inserted into KieSession and then fireAllRules() called, the rule does not fire.

If the import statement is changed to the following

import org.drools.compiler.integrationtests.facts.TestEvent

the rule fires as expected.

The problem is not present when using old API (KnowledgeBase), so this is a regression.

The tricky part is, that no error is reported, the engine just behaves as if the fact declared in DRL and the fact imported from Java were two different facts.

Version-Release number of selected component (if applicable):

BRMS 6.0.0 DR5
Drools 6.0.0.Beta3
Drools 6.0.0-SNAPSHOT

How reproducible:

Run the StarImportTest from attached pull request (will add reference to the pull request shortly).

Actual results:

The rule does not fire.

Expected results:

The rule fires.
Comment 1 Marek Winkler 2013-06-11 11:04:13 EDT
Pull request with reproducer: https://github.com/droolsjbpm/drools/pull/213
Comment 2 Mario Fusco 2013-07-25 07:58:34 EDT
Fixed on CR2.
Comment 3 Marek Winkler 2013-09-02 05:09:10 EDT
Verified on BRMS 6.0.0-ER2.

Note You need to log in before you can comment on or make changes to this bug.