Bug 973268 - ticketmonster-cordova (2.3.0.ER1) iOS contains a debugging alert box
ticketmonster-cordova (2.3.0.ER1) iOS contains a debugging alert box
Status: CLOSED NOTABUG
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TicketMonster (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Marek Novotny
Tomas Repel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 11:17 EDT by Tolis Emmanouilidis
Modified: 2014-03-03 19:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 05:57:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Final Order screen with alert (175.09 KB, image/png)
2013-06-11 11:17 EDT, Tolis Emmanouilidis
no flags Details

  None (edit)
Description Tolis Emmanouilidis 2013-06-11 11:17:41 EDT
Created attachment 759694 [details]
Final Order screen with alert

Description of problem:
When completing an order either 'By Location' or 'By Category' and click the 'Buy' button, then a debugging alert appears.

Version-Release number of selected component (if applicable):
2.3.0.ER1

How reproducible:
Open the ticketmonster-cordova in XCode and make an order 'By Location' or 'By Category'.

Steps to Reproduce:
1. Open the ticketmonster-cordova in XCode
2. Compile it and open it on the iPhone simulator
3. Select 'By Category'
4. Select Sporting
5. Select Brazil vs Italy
6. Select Toronto: BMO Field venue
7. Select Tue 12 November 2013 show date
8. Select 03:00 show date
9. Click to book
10. Select B Premium gold reserve section
11. Fill amount 199.5
12. Fill email qa@example.com
13. Click checkout
14. Click Buy


Actual results:
A JavaScript alert appears


Expected results:
The final order should appear

Additional info:
Added screenshot
Comment 1 Tolis Emmanouilidis 2013-06-13 05:57:16 EDT
After investigating the source code, it seems that the alert box appears in case of trying to fulfil an invalid order (e.g when the quantity number is high).

In conclusion the alert box correctly appears and it is not a bug.

Note You need to log in before you can comment on or make changes to this bug.