Bug 973283 - Inconsistent naming of products
Summary: Inconsistent naming of products
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Configuration (Show other bugs)
(Show other bugs)
Version: 6.0.0
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ---
: 6.0.0
Assignee: Prakash Aradhya
QA Contact: Radovan Synek
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-11 15:40 UTC by Radovan Synek
Modified: 2014-08-06 20:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 20:08:09 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Radovan Synek 2013-06-11 15:40:24 UTC
1)

BAM deployed on EAP6 is accessible on URL http://host:port/bam-app

I do not consider this name - "bam-app" - appropriate for the product, what about some better naming? Maybe "dashboards" or "bam" ?

Moreover, when using deployable binaries (for example on tomcat7) BAM is accessible on URL http://host:port/dashbuilder.

At least I would expect consistent naming in URL across all supported containers.

2)

Second inconsistence in naming is between business-central (BPMS) and jboss-brms (BRMS). In fact, it is the same application (with more or less features), so the naming should be identical in both BRMS and BPMS product => no "jboss-brms", only "business-central" or whatever.

Comment 3 Pedro Zapata 2013-06-18 09:42:25 UTC
>> BAM deployed on EAP6 is accessible on URL http://host:port/bam-app

The preset context is /dashbuilder and where is deployed. The issue is that the links in the home screen are wrong, and the jBPM Uberfire panel has not yet been integrated. We are fixing both issues during this week.

So the right path will be: http://host:port/dashbuilder

Comment 4 Ryan Zhang 2013-06-20 12:46:07 UTC
The dashbuilder war url is recovered to http://host:port/dashbuilder in the latest DR5.

Comment 8 Radovan Synek 2014-03-18 16:17:38 UTC
qe_test_coverage: see the summary


Note You need to log in before you can comment on or make changes to this bug.