Bug 973313 - cancelling iso repo sync error pulp.log
cancelling iso repo sync error pulp.log
Status: CLOSED DUPLICATE of bug 950772
Product: Pulp
Classification: Community
Component: iso-support (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Randy Barlow
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 12:31 EDT by Preethi Thomas
Modified: 2013-06-12 10:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 10:03:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2013-06-11 12:31:01 EDT
Description of problem:

If you cancel a repo sync through tasks cancel, the tasks gets cancelled with tracebacks in the pulp.log

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. cancel a running iso repo sync
2.tail the log
3.

Actual results:


[root@hp-dl360g6-01 ~]# pulp-admin iso repo sync run --repo-id file-repo+----------------------------------------------------------------------+
                  Synchronizing Repository [file-repo]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading the Pulp Manifest...
The Pulp Manifest was downloaded successfully.

Downloading 3 ISOs...
[================================                  ] 64%
ISOs: 2/3	Data: 6.7 MB/10.2 MB	Avg: 852.1 kB/s


Failed to retrieve 1 ISOs.

The download was cancelled.

2013-06-11 12:19:12,972 pulp.server.managers.repo.sync:ERROR: Exception caught from plugin during sync for repo [file-repo]
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/server/managers/repo/sync.py", line 155, in _do_sync
    sync_report = importer_instance.sync_repo(transfer_repo, conduit, call_config)
  File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/iso_importer/importer.py", line 111, in sync_repo
    report = self.iso_sync.perform_sync()
  File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/iso_importer/sync.py", line 170, in perform_sync
    self.progress_report.state = self.progress_report.STATE_COMPLETE
  File "/usr/lib/python2.7/site-packages/pulp_rpm/common/progress.py", line 294, in _set_state
    super(self.__class__, self)._set_state(new_state)
  File "/usr/lib/python2.7/site-packages/pulp_rpm/common/progress.py", line 165, in _set_state
    if new_state not in self.ALLOWED_STATE_TRANSITIONS[self._state]:
KeyError: 'cancelled'
2013-06-11 12:19:12,977 pulp.server.dispatch.task:ERROR: Pulp exception occurred: PulpExecutionException
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/server/dispatch/task.py", line 138, in _run
    result = call(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pulp/server/managers/repo/sync.py", line 111, in sync
    sync_result = self._do_sync(repo, importer_instance, transfer_repo, conduit, call_config)
  File "/usr/lib/python2.7/site-packages/pulp/server/managers/repo/sync.py", line 155, in _do_sync
    sync_report = importer_instance.sync_repo(transfer_repo, conduit, call_config)
  File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/iso_importer/importer.py", line 111, in sync_repo
    report = self.iso_sync.perform_sync()
  File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/importers/iso_importer/sync.py", line 170, in perform_sync
  self.progress_report.state = self.progress_report.STATE_COMPLETE
  File "/usr/lib/python2.7/site-packages/pulp_rpm/common/progress.py", line 294, in _set_state
    super(self.__class__, self)._set_state(new_state)
  File "/usr/lib/python2.7/site-packages/pulp_rpm/common/progress.py", line 165, in _set_state
    if new_state not in self.ALLOWED_STATE_TRANSITIONS[self._state]:
PulpExecutionException: Pulp exception occurred: PulpExecutionException
2013-06-11 12:19:12,981 pulp.server.dispatch.task:INFO: FAILURE: Task b26af372-42ce-426d-a4d2-f604d82e5826: CallRequest: RepoSyncManager.sync(u'file-repo', sync_config_override=None)





Expected results:


Additional info:
Comment 1 Randy Barlow 2013-06-11 13:01:03 EDT
This was already reported in comment three of another bug[0]. I already fixed it, but it hasn't been merged yet (waiting for review). Should we mark this a duplicate?

[0] https://bugzilla.redhat.com/show_bug.cgi?id=950772#c3
Comment 2 Jay Dobies 2013-06-12 10:03:16 EDT

*** This bug has been marked as a duplicate of bug 950772 ***

Note You need to log in before you can comment on or make changes to this bug.