Bug 973320 - ticketmonster-cordova (2.3.0.ER1) Android issues
ticketmonster-cordova (2.3.0.ER1) Android issues
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TicketMonster (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity low
: CR1
: 2.3.0
Assigned To: Marek Novotny
Tomas Repel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 12:48 EDT by Tolis Emmanouilidis
Modified: 2014-03-03 19:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:32:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Footer 4.1.2 (56.44 KB, image/png)
2013-06-11 12:48 EDT, Tolis Emmanouilidis
no flags Details
Footer 2.3.3 (52.78 KB, image/png)
2013-06-11 12:49 EDT, Tolis Emmanouilidis
no flags Details
Alert box (59.06 KB, image/png)
2013-06-11 12:50 EDT, Tolis Emmanouilidis
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JDF-369 Major Resolved ticket-monster cordova android add fixed Footer 2013-07-02 03:43:40 EDT

  None (edit)
Description Tolis Emmanouilidis 2013-06-11 12:48:54 EDT
Created attachment 759726 [details]
Footer 4.1.2

Description of problem:
While trying to complete the order, a debugging alert box appears. In addition the order stops at the confirmation step and cannot get completed. There is also an issue with the footer which is not positioned at the end of the screen.

Version-Release number of selected component (if applicable):
2.3.0.ER1

How reproducible:
Open the application in an Android emulator through JBDS

Steps to Reproduce:
1. Import the project in JBDS
2. Create an emulator
3. Run the application in the emulator

Actual results:
Debugging alert appears, not fixed footer, order cannot get completed

Expected results:
The debugging alert should not appear, the footer should be fixed at the bottom of the screen and the order should get completed.

Additional info:
Attached screenshots for all described issues
Comment 1 Tolis Emmanouilidis 2013-06-11 12:49:55 EDT
Created attachment 759727 [details]
Footer 2.3.3
Comment 2 Tolis Emmanouilidis 2013-06-11 12:50:23 EDT
Created attachment 759728 [details]
Alert box
Comment 3 Tolis Emmanouilidis 2013-06-13 05:56:16 EDT
After investigating the source code, it seems that the alert box appears in case of trying to fulfil an invalid order (e.g when the quantity number is high).

In conclusion the alert box correctly appears and it is not a bug.

There only remaining issue is related with the footer which is not positioned at the end of the screen.
Comment 5 JBoss JIRA Server 2013-06-13 09:46:28 EDT
Vineet Reynolds <vineet.reynolds@gmail.com> updated the status of jira JDF-369 to Resolved
Comment 6 JBoss JIRA Server 2013-06-13 09:46:28 EDT
Vineet Reynolds <vineet.reynolds@gmail.com> made a comment on jira JDF-369

Pushed upstream https://github.com/jboss-jdf/ticket-monster/commit/2ce04e054fe013581375eb7b8641ff9d3710e3a1

Note You need to log in before you can comment on or make changes to this bug.