Bug 97333 - Downing an interface alias downs another interface with same subnet, network and broadcast address
Downing an interface alias downs another interface with same subnet, network ...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-13 03:29 EDT by Dhyanesh Ramaiya
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 08:06:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dhyanesh Ramaiya 2003-06-13 03:29:26 EDT
Description of problem: Downing an interface alias with different IP but same 
network, broadcast and subnet addresses, downs another interface alias with 
with the same network, broadcast and subnet addresses


Version-Release number of selected component (if applicable): net-tools-1.60-12


How reproducible: 


Steps to Reproduce:
1. Create two interface aliases

2. Let the network, broadcast and subnet addresses be the same for both the 
interfaces (but different IP addresses)

#Interface eth1:1
DEVICE=eth1:1
BROADCAST=1.2.3.223
IPADDR=1.2.3.193
NETMASK=255.255.255.224
NETWORK=1.2.3.192
ONBOOT=yes
TYPE=Ethernet

#Interface eth1:2
DEVICE=eth1:2
BOOTPROTO=static
NETMASK=255.255.255.224
NETWORK=1.2.3.192
IPADDR=1.2.3.196
BROADCAST=1.2.3.223
ONBOOT=yes

3. The IP subnet begins at 1.2.3.192. Issue "ifconfig eth1:2 down" and it will 
also down eth1:1

    
Actual results: "ifconfig eth1:2 down" downs interface eth1:1 as well. 


Expected results: Downing eth1:2 should not down eth1:1


Additional info:
Comment 1 Phil Knirsch 2003-08-19 08:06:12 EDT
I think thats to be expected: The alias interfaces actually refere to the same
physical interface, so if you put that down all aliased interfaces go down, too.

Also i think this is not a problem of the tool but of the kernel (if at all).

Read ya, Phil
Comment 2 Phil Knirsch 2003-08-19 08:18:34 EDT
Additionally, i just asked on of our kernel developers: The 'old' style aliasing
(which you are using) is actually really handled as separate interfaces, so
ifconfig down of any of those interfaces only shuts down that interface. I just
tested it on our current Beta, but the behaviour was like that since 2.4.0.

So i can't reproduce your problem.

It's different if you use the new aliasing method via the ip tool. There you can
assigne multiple ip addresses to a single interface, and of course if you shut
down that interface all assigned ip addresses will be unreachable.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.