Bug 973351 - rhc cartridge list is displaying dups
rhc cartridge list is displaying dups
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 14:36 EDT by Nam Duong
Modified: 2015-05-14 19:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:53:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2013-06-11 14:36:28 EDT
Description of problem:
Since the cartridge list is showing duplicates for php and ruby cartridges, I get an error when I try to run:  
> rhc app create wordpress php-5 mysql-5 --from-code=https://github.com/openshift/wordpress-example
Using mysql-5.1 (MySQL Database 5.1) for 'mysql-5'

Short Name Full name
========== =========
php-5.3    PHP 5.3
php-5.3    PHP 5.3


I'm forced to run:
> rhc app create wordpress php-5.3 mysql-5 --from-code=https://github.com/openshift/wordpress-example
Using mysql-5.1 (MySQL Database 5.1) for 'mysql-5'

Application Options
-------------------
  Namespace:   macdomain
  Cartridges:  php-5.3, mysql-5.1
  Source Code: https://github.com/openshift/wordpress-example
  Gear Size:   default
  Scaling:     no


This is confusing users as they're not sure which version of cartridge to use as well as which version will actually get deployed - although the later was validated that we're using v2 (at least for php-5.3).  

Also see "rhc cartridge list"
Comment 1 Paul Morie 2013-06-11 14:39:59 EDT
The root cause here is that the node is reporting both installed versions of the V2 php-5.3 cartridge.
Comment 2 Paul Morie 2013-06-11 18:02:54 EDT
I've made a quick fix for this and put in PRs for stage and master.  I am leaving this issue in modified because we need to discuss whether the quick fix is good enough.
Comment 3 openshift-github-bot 2013-06-11 22:57:36 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/f8c67f8ef2a33bd1d82793222886514cb0c54f4f
Fix bug 973351: Add CartridgeRepository.latest_versions for use in rhc cartridge list
Comment 4 Meng Bo 2013-06-13 06:37:40 EDT
Checked on devenv_3355,

1.Toggle the cartridge version between v1 and v2.
2.Create app with fuzzy short name.
rhc app create php1 php-5 -pxx

3. App creation successfully.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.