Bug 973355 - sanity check not catching missing /boot/efi on UEFI
sanity check not catching missing /boot/efi on UEFI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:4e1b694046950b00fa383f5208e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 14:47 EDT by A.J. Werkman
Modified: 2013-06-28 03:17 EDT (History)
9 users (show)

See Also:
Fixed In Version: python-blivet-0.17-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 03:17:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (380.95 KB, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: anaconda.log (10.97 KB, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: backtrace (713 bytes, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: environ (536 bytes, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: ifcfg.log (520 bytes, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: lsblk_output (1.34 KB, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: nmcli_dev_list (1.28 KB, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: packaging.log (22.80 KB, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: program.log (36.03 KB, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: storage.log (137.91 KB, text/plain)
2013-06-11 14:47 EDT, A.J. Werkman
no flags Details
File: syslog (140.66 KB, text/plain)
2013-06-11 14:48 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2013-06-11 14:47:14 EDT
Description of problem:
The following was filed automatically by anaconda:
anaconda 19.30.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 320, in doIt
    if boot.type == "mdarray":
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'NoneType' object has no attribute 'type'

Version-Release number of selected component:
anaconda-19.30.3-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.sshd nomodeset inst.ks=cdrom:/dev/cdrom:/ks.cfg ip=172.18.92.70::172.18.92.65:255.255.255.192:cfl.lc.digifarma.nl::none nameserver=172.18.92.65 inst.stage2=hd:CDLABEL=CFL_080T
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-TC2

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 320, in doIt
    if boot.type == "mdarray":
AttributeError: 'NoneType' object has no attribute 'type'
Comment 1 A.J. Werkman 2013-06-11 14:47:20 EDT
Created attachment 759760 [details]
File: anaconda-tb
Comment 2 A.J. Werkman 2013-06-11 14:47:24 EDT
Created attachment 759761 [details]
File: anaconda.log
Comment 3 A.J. Werkman 2013-06-11 14:47:27 EDT
Created attachment 759762 [details]
File: backtrace
Comment 4 A.J. Werkman 2013-06-11 14:47:31 EDT
Created attachment 759763 [details]
File: environ
Comment 5 A.J. Werkman 2013-06-11 14:47:34 EDT
Created attachment 759764 [details]
File: ifcfg.log
Comment 6 A.J. Werkman 2013-06-11 14:47:40 EDT
Created attachment 759765 [details]
File: lsblk_output
Comment 7 A.J. Werkman 2013-06-11 14:47:43 EDT
Created attachment 759766 [details]
File: nmcli_dev_list
Comment 8 A.J. Werkman 2013-06-11 14:47:48 EDT
Created attachment 759767 [details]
File: packaging.log
Comment 9 A.J. Werkman 2013-06-11 14:47:53 EDT
Created attachment 759768 [details]
File: program.log
Comment 10 A.J. Werkman 2013-06-11 14:47:57 EDT
Created attachment 759769 [details]
File: storage.log
Comment 11 A.J. Werkman 2013-06-11 14:48:02 EDT
Created attachment 759771 [details]
File: syslog
Comment 12 David Lehman 2013-06-11 15:02:42 EDT
Looks like the user is trying to install on UEFI without creating a /boot/efi filesystem and for some reason we are not catching this error and instead allow the (doomed) install to proceed.
Comment 13 Brian Lane 2013-06-18 12:55:50 EDT
Patches from http://dlehman.fedorapeople.org/patches/20130430-efi.0/ fixes this in my testing.
Comment 14 Fedora Update System 2013-06-24 17:59:51 EDT
anaconda-19.30.10-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.10-1.fc19
Comment 15 Fedora Update System 2013-06-25 17:17:45 EDT
Package python-blivet-0.17-1.fc19, anaconda-19.30.11-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.17-1.fc19 anaconda-19.30.11-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11679/python-blivet-0.17-1.fc19,anaconda-19.30.11-1.fc19
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-06-26 13:10:43 EDT
Package python-blivet-0.17-1.fc19, anaconda-19.30.12-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.17-1.fc19 anaconda-19.30.12-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11679/python-blivet-0.17-1.fc19,anaconda-19.30.12-1.fc19
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2013-06-28 03:17:51 EDT
python-blivet-0.17-1.fc19, anaconda-19.30.13-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.