This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 973360 - not able to do node sync on iso repos
not able to do node sync on iso repos
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: nodes (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Ortel
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 14:53 EDT by Preethi Thomas
Modified: 2013-06-11 16:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 16:22:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2013-06-11 14:53:08 EDT
Description of problem:
Node sync running on isp repo seems to be not syncing the iso repo to the node child

Version-Release number of selected component (if applicable):

[root@hp-dl360g6-01 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.3.beta.fc18.noarch
[root@hp-dl360g6-01 ~]# 

How reproducible:


Steps to Reproduce:
1.create a an iso repo
2. enable & publish the repo for node sync
3. run node sync

Actual results:

iso repo not synced on the node

Expected results:


Additional info:
Comment 1 Preethi Thomas 2013-06-11 16:22:55 EDT
closing. I did not bind the repo to node

[root@hp-dl360g6-01 ~]# pulp-admin node bind --node-id node1 --repo-id file-repo
Node bind succeeded.

Note: Repository [ file-repo ] will be included in node synchronization.

[root@hp-dl360g6-01 ~]# pulp-admin node sync run --node-id node1 
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...



(1/2) Repository: f18
[==================================================] 100%


(2/2) Repository: file-repo
[==================================================] 100%




Synchronization succeeded

+----------------------------------------------------------------------+
                       Child Node Synchronization
+----------------------------------------------------------------------+

Repository: 
  Action: Merged
  Id:     f18
  Units:  
    Added:   0
    Removed: 0
    Updated: 0

Repository: 
  Action: Added
  Id:     file-repo
  Units:  
    Added:   3
    Removed: 0
    Updated: 0



[root@hp-dl360g6-01 ~]#

Note You need to log in before you can comment on or make changes to this bug.