Bug 973377 - require attr from pam_openshift
require attr from pam_openshift
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: chris alfonso
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 15:34 EDT by Luke Meyer
Modified: 2017-03-08 12 EST (History)
6 users (show)

See Also:
Fixed In Version: pam_openshift-1.6.3-1
Doc Type: Bug Fix
Doc Text:
The oo-init-namespace command failed while attempting to set appropriate attributes if the attr package was not installed. With this fix, the RPM spec file for the pam_openshift package is updated to include attr as a dependency to ensure it is installed correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:16:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Meyer 2013-06-11 15:34:11 EDT
In the (exceedingly unlikely) case that the "attr" RPM isn't installed, oo-namespace-init will bomb trying to set appropriate attributes. "attr" is in the minimal install but at least one customer managed to run into this, so might as well make it explicit.
Comment 1 Luke Meyer 2013-06-11 15:35:00 EDT
There is really no need to complicate the release, though.
Comment 3 chris alfonso 2013-06-12 09:58:35 EDT
This will be fixed upstream: https://github.com/openshift/origin-server/pull/2822
Comment 6 Gaoyun Pei 2013-07-15 22:59:19 EDT
Verify this on puddle: 2013-07-12.

After the installation of OSE, check the dependency of pam_openshift:
[root@node ~]# yum deplist pam_openshift |grep attr
  dependency: attr
   provider: attr.x86_64 2.4.44-4.el6
   provider: attr.x86_64 2.4.44-7.el6
  dependency: libattr.so.1()(64bit)
   provider: libattr.x86_64 2.4.44-4.el6
   provider: libattr.x86_64 2.4.44-7.el6

Package attr has been list as a dependency, so move it to VERIFIED.
Comment 9 errata-xmlrpc 2013-08-05 13:16:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.