Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 973389 - pymongo 2.5.2 available upstream
pymongo 2.5.2 available upstream
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pymongo (Show other bugs)
18
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Andrew McNabb
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 16:29 EDT by Johan Hedin
Modified: 2013-07-09 21:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-pymongo-2.5.2-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:10:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Hedin 2013-06-11 16:29:00 EDT
PyMongo 2.5.2 is available upstream. Fixes a couple of bugs and a NULL pointer dereference:

https://jira.mongodb.org/browse/PYTHON/fixforversion/12484
https://jira.mongodb.org/browse/PYTHON/fixforversion/12581
Comment 1 Johan Hedin 2013-06-11 16:31:24 EDT
pymongo 2.5.2 builds cleanly with the current spec-file (2.5-5) if the following two tests are added the the list of excluded tests:

test_client
test_replica_set_client
Comment 2 Fedora Update System 2013-06-12 15:36:47 EDT
python-pymongo-2.5.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-pymongo-2.5.2-1.fc19
Comment 3 Fedora Update System 2013-06-12 15:37:56 EDT
python-pymongo-2.5.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-pymongo-2.5.2-1.fc18
Comment 4 Andrew McNabb 2013-06-12 15:39:50 EDT
Thanks for doing most of the work.
Comment 5 Johan Hedin 2013-06-12 15:54:57 EDT
Glad to help out!
Comment 6 Fedora Update System 2013-06-13 02:07:37 EDT
Package python-pymongo-2.5.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-pymongo-2.5.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10701/python-pymongo-2.5.2-1.fc18
then log in and leave karma (feedback).
Comment 7 Johan Hedin 2013-06-13 16:56:23 EDT
Works for me on Fedora 18 x86_64.
Comment 8 Fedora Update System 2013-06-20 12:05:14 EDT
python-pymongo-2.5.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-pymongo-2.5.2-2.fc18
Comment 9 Fedora Update System 2013-06-29 14:10:59 EDT
python-pymongo-2.5.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-07-09 21:23:32 EDT
python-pymongo-2.5.2-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.