Bug 97339 - Date/Time during install wrong for Aus/Sydney Timezone
Date/Time during install wrong for Aus/Sydney Timezone
Status: CLOSED DUPLICATE of bug 6175
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-13 07:54 EDT by Andrew Smith
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Smith 2003-06-13 07:54:37 EDT
Description of problem:
Machine was running RH8.0 with correct time (hardware clock and software clock)
Ran install of RH9 and selected my local timezone Sydney/Australia
After install completes the date/time of some of the top level directories are 
in the future as are some files in /etc/mail (sendmail startup gives a message 
about this)

This has occurred on earlier versions of RH also with many different computers 
(and always happens) but this is the first time I have checked all the 
dates/times before and after the install.

My timezone is +1000
The time in the future appears to be about 11 hours (i.e. 11 hours in the 
future from around the time the install started) however during daylight 
savings my timeszone is +1100

Version-Release number of selected component (if applicable):


How reproducible:
Every Time

Steps to Reproduce:
1. Start Install
2. Note Time packages start being copied to disk
3. use date and ls on / and /etc/mail after first boot
    
Actual results:
I have removed the uid and filesize to make the 'ls' output smaller
$ date
Fri Jun 13 21:35:48 EST 2003
$ ls -ort --full-time /
total 193
drwxr-xr-x    2 2003-01-25 10:52:28.000000000 +1100 opt
drwxr-xr-x    2 2003-01-25 10:52:28.000000000 +1100 initrd
drwxr-xr-x    2 2003-01-25 10:52:28.000000000 +1100 home
drwxr-xr-x    2 2003-01-28 15:22:54.000000000 +1100 misc
drwxr-xr-x    4 2003-06-13 21:29:08.000000000 +1000 mnt
drwxr-xr-x   43 2003-06-13 21:29:10.000000000 +1000 etc
drwxrwxrwt    2 2003-06-13 21:30:44.000000000 +1000 tmp
drwxr-xr-x   20 2003-06-13 21:30:48.000000000 +1000 dev
drwx------    2 2003-06-14 05:18:30.000000000 +1000 lost+found
drwxr-xr-x   15 2003-06-14 05:32:24.000000000 +1000 usr
drwxr-xr-x    4 2003-06-14 05:41:38.000000000 +1000 boot
drwxr-xr-x    2 2003-06-14 05:53:38.000000000 +1000 sbin
drwxr-xr-x   18 2003-06-14 05:54:19.000000000 +1000 var
drwxr-xr-x    7 2003-06-14 06:58:51.000000000 +1000 lib
drwxr-xr-x    2 2003-06-14 06:59:19.000000000 +1000 bin
drwxr-x---    3 2003-06-14 07:26:47.000000000 +1000 root
dr-xr-xr-x   43 2003-06-14 07:28:17.000000000 +1000 proc
$ ls -ort --full-time /etc/mail
total 216
-rw-------    1 2003-02-25 11:15:54.000000000 +1100 statistics
-rw-r--r--    1 2003-02-25 11:15:54.000000000 +1100 helpfile
-r--r--r--    1 2003-02-25 11:15:55.000000000 +1100 submit.cf.bak
-rw-r--r--    1 2003-02-25 11:15:55.000000000 +1100 sendmail.mc
-rw-r--r--    1 2003-02-25 11:15:56.000000000 +1100 virtusertable
-rw-r--r--    1 2003-02-25 11:15:56.000000000 +1100 trusted-users
-rw-r--r--    1 2003-02-25 11:15:56.000000000 +1100 submit.mc
-rw-r--r--    1 2003-02-25 11:15:56.000000000 +1100 Makefile
-rw-r--r--    1 2003-02-25 11:15:56.000000000 +1100 mailertable
-rw-r--r--    1 2003-02-25 11:15:56.000000000 +1100 local-host-names
-rw-r--r--    1 2003-02-25 11:15:56.000000000 +1100 domaintable
-rw-r--r--    1 2003-02-25 11:15:56.000000000 +1100 access
-rw-r--r--    1 2003-06-13 21:30:45.000000000 +1000 submit.cf
-rw-r--r--    1 2003-06-14 05:50:46.000000000 +1000 sendmail.cf
-rw-r-----    1 2003-06-14 05:50:47.000000000 +1000 virtusertable.db
-rw-r-----    1 2003-06-14 05:50:49.000000000 +1000 access.db
-rw-r-----    1 2003-06-14 05:50:50.000000000 +1000 domaintable.db
-rw-r-----    1 2003-06-14 05:50:51.000000000 +1000 mailertable.db

Expected results:
All of the future dated files should be in the past at the time of the 'ls' 
command

Additional info:
Comment 1 Andrew Smith 2003-06-14 00:12:32 EDT
FYI: I didn't select UTC when selecting the timezone
Comment 2 Jeremy Katz 2003-08-06 16:29:21 EDT

*** This bug has been marked as a duplicate of 6175 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:56:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.