Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 973450 - File attribute always replaces the file even if the values are equal
Summary: File attribute always replaces the file even if the values are equal
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER3
: EAP 6.1.1
Assignee: James Perkins
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-11 23:31 UTC by James Perkins
Modified: 2013-09-16 20:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
There was an issue in previous versions of JBoss EAP 6 in which logging events that were recorded during bootstrapping by a file log handler would be overwritten. This issue would occur if the file log handler was not set to append. This issue occurred because the logging subsystem did not not properly check the value for the `FILE` attribute of the file log handler when comparing it to the value used during bootstrapping. In this release of JBoss EAP 6, the logging subsystem has been updated to fix this issue. For file log handlers that are not set to append, the `FILE` attribute is now properly checked against the value used during bootstrapping, so that events that are recorded during bootstrapping are no longer overwritten.
Clone Of:
Environment:
Last Closed: 2013-09-16 20:29:21 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker WFLY-1500 0 Major Resolved File attribute always replaces the file even if the values are equal 2014-08-13 10:51:00 UTC

Description James Perkins 2013-06-11 23:31:36 UTC
Description of problem:
The value for the FILE attribute for file log handlers isn't properly checked when comparing bootstrap file value. With a file that is not appendable, the overwrite would overwrite bootstrapped logged data.

Steps to Reproduce:
1. Create any file handler and set append to false

Actual results:
Bootstrap logged data is not available in file


Expected results:
Bootstrap logged data to be available in file

Comment 2 JBoss JIRA Server 2013-06-18 19:09:23 UTC
James Perkins <jperkins@redhat.com> made a comment on jira WFLY-1500

Pull request merged

Comment 3 Petr Kremensky 2013-07-22 13:17:20 UTC
Verified on EAP 6.1.1 ER3, bootstrap logged are now not overwritten.


Note You need to log in before you can comment on or make changes to this bug.