Bug 973455 - /dev/dvd* symlinks not showing up in Fedora 19
/dev/dvd* symlinks not showing up in Fedora 19
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 19:54 EDT by Martin Jackson
Modified: 2013-06-17 13:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 13:07:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jackson 2013-06-11 19:54:09 EDT
Description of problem:  I expect to see symlinks in /dev such as /dev/dvd, /dev/dvdrw, /dev/dvd1 etc.  Some userland utilities (such as lsdvd) expect these to be present and emit strange error messages when the links are unavailable.  The actual device nodes (/dev/sr0 and /dev/sr1) are present, and work.  There is a /dev/cdrom symlink.


Version-Release number of selected component (if applicable):
systemd-204-6.fc19.x86_64
systemd-libs-204-6.fc19.x86_64


How reproducible:  Every time.


Steps to Reproduce:
1.  Boot system
2.  ls -l /dev/dvd


Actual results:  File not found


Expected results:  A symlink to /dev/sr0


Additional info:
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    1.269456] ata2.00: ATAPI: PLDS DVD-ROM DH-16D3S, SD11, max UDMA/100
[    1.269534] ata3.00: ATAPI: TSSTcorp DVD+/-RW TS-H653F, D200, max UDMA/100
[    1.275035] scsi 1:0:0:0: CD-ROM            PLDS     DVD-ROM DH-16D3S SD11 PQ: 0 ANSI: 5
[    1.277625] sr0: scsi3-mmc drive: 48x/48x cd/rw xa/form2 cdda tray
[    1.277768] sr 1:0:0:0: Attached scsi CD-ROM sr0
[    1.277853] sr 1:0:0:0: Attached scsi generic sg1 type 5
[    1.278420] scsi 2:0:0:0: CD-ROM            TSSTcorp DVD+-RW TS-H653F D200 PQ: 0 ANSI: 5
[    1.280540] sr1: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[    1.280665] sr 2:0:0:0: Attached scsi CD-ROM sr1
[    1.280756] sr 2:0:0:0: Attached scsi generic sg2 type 5
Comment 1 Kay Sievers 2013-06-17 13:07:21 EDT
/dev/srX is created by the kernel, and reflects the actual setup.

For /dev/sr0, and only for that, the symlink /dev/cdrom will be created.

Systemd/udev does not create any other symlinks for optical drives since quite
a while.

If any such specific links are needed,
  /dev/disk/by-id/
links should be used, or custom udev rules need to be added manually.

There is no support for specific links for optical drive device classes
or enumerated links like in the default setup.

Note You need to log in before you can comment on or make changes to this bug.