Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 973469 - F18 PostgreSQL packages omit a systemd servce definition or daemon launch script
Summary: F18 PostgreSQL packages omit a systemd servce definition or daemon launch script
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql
Version: 18
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Pavel Raiskup
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-12 01:43 UTC by Martin Gregorie
Modified: 2013-06-12 12:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-12 12:07:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Gregorie 2013-06-12 01:43:13 UTC
Description of problem: 
=======================
I've just done a clean install of 32 bit Fedora 18 PAE and am expecting to run Postgresql under it. Unfortunately, none of the postgresql packages appear to contain either a copy of the old SysVinit daemon launch script or a replacement postgresql.service file: there was no script placed in /etc/rc.d/init.d and locate can't find a postgres.service file

Version-Release number of selected component (if applicable):
================
postgresql 9.2.4

How reproducible:
=================
Simple: do a clean install of Fedora 18, followed by "

    yum install postgresql* --skip-broken

and all the packages except postgresql-plparrot-0.05-3.fc18.i686, which fails because it needs libparrot.so.5.0.0  - from the look of it, the absence of this package does not affect this issue: I'd expect the control scripts and service definitions to be in the postgresql-server package.

Steps to Reproduce:
===================
1. Clean install of F18 (32 bit, with XFCE as desktop. 
   Developer and Libre Office packages selected.
   Use separate partitions for /, /boot, /home and /tmp

2. This doesn't install PostgreSQL, so install it: yum postgresql* --skip-broken
   so the problem with libparrot isn't a show stopper.

3. Now try to enable the PostgreSQL service and you'll find it is impossible
   because there is no postgresql.service file and no 'postgresql' daemon
   launcher in /etc/rc.d/init.d either

Actual results:
===============
PostgresQL 9.2.4 is successfully installed but can't be enabled or started because there is no service definition.

Expected results:
=================
To have the service definition installed so PostgreSQL can be enabled and started/

Additional info:
================
None.

Comment 1 Devrim Gündüz 2013-06-12 12:02:27 UTC
Hi,


The service file is here:

/usr/lib/systemd/system/postgresql.service

So it is not "postgres.service".

(Please note that there is no /etc/init.d/ anymore, in most of the services)

Regards, Devrim


Note You need to log in before you can comment on or make changes to this bug.