Bug 97347 - Connection returns no data after certificate exchange for non-kickstart (CD based) Install
Connection returns no data after certificate exchange for non-kickstart (CD b...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
Red Hat Satellite QA List
:
Depends On:
Blocks: 88391
  Show dependency treegraph
 
Reported: 2003-06-13 10:36 EDT by Joe deBlaquiere
Modified: 2007-07-31 10:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-16 16:51:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe deBlaquiere 2003-06-13 10:36:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After completing installation of satellite on a system which is a new clean
install of AS2.1-QU2 connection to https://FQDN/ returns "document contains no
data" after the web client has received the SSL certificate. 

Apache is running as browsing to https://FQDN/pub/ returns a directory of the
information in there. 

Also, /var/log/httpd/error_log has several (~6) "[notice] child pid <PID> exit
signal Illegal instruction on (4)" errors after the connection attempt.

Version-Release number of selected component (if applicable):
rhn-satellite-2.0-39

How reproducible:
Always

Steps to Reproduce:
1. Install QU2 from CDs
2. Install Satellite (-39)
3. Connect With Mozilla to https:
    

Actual Results:  "document contains no data"

Expected Results:  nirvana

Additional info:
Comment 1 Greg DeKoenigsberg 2003-06-13 11:38:52 EDT
We've traced this issue down to a silent failure in the satellite installer.  We
 remove php using "rpm -qa | grep php | xargs rpm -e", but on a vanilla AS 2.1
QU2 install, this action fails because piranha depends upon php.  So the end
result is that we do NOT remove php, and it breaks everything in sight.

This flaw was in evidence in the -39 installer, and we have no reason to believe
that it's been fixed in subsequent revisions.  To fix, we'll need to identify
all potentially installed packages that depend upon php.  (Piranha is the only
one I've found to date.)

Comment 2 Chip Turner 2003-06-13 12:57:10 EDT
fixed in cvs; repaired the broken rhnweb Conflicts, made the installer check to
see if php was removed and errir of not, and added piranha to be removed along
with php in case it is present.
Comment 3 Josef Komenda 2003-06-18 09:59:26 EDT
Looks good in -47. Moving this to PROD_READY and investigating exception
handling in bug #84829
Comment 4 Josef Komenda 2003-07-16 16:51:54 EDT
Looks good in prod. 

Note You need to log in before you can comment on or make changes to this bug.