Bug 973510 - should give root user required error before resolving dependencies
should give root user required error before resolving dependencies
Status: CLOSED DUPLICATE of bug 910133
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 01:32 EDT by Parag Nemade
Modified: 2013-06-18 03:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 03:56:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2013-06-12 01:32:25 EDT
Description of problem:
When yum used as a normal user
$ yum update
Loaded plugins: langpacks, refresh-packagekit
You need to be root to perform this command.

But, when dnf used as a normal user
$ dnf update --enablerepo=updates-testing
Setting up Upgrade Process
Resolving Dependencies
--> Starting dependency resolution
.....
<Snip>
.....
Is this ok [y/N]: y
Downloading Packages:
Unable to initialize yumdb history: [Errno 13] Permission denied: '//var/lib/dnf'


Version-Release number of selected component (if applicable):
dnf-0.3.7-1.gitf8bdc98.fc19

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
dnf command is not checking for admin user status and performs Resolving Dependencies


Expected results:
dnf should check if the user requesting is non-root and then accordingly error and quit

Additional info:
Comment 1 Zdeněk Pavlas 2013-06-12 03:48:04 EDT
Yep, this got merged by mistake:

commit b98716756f0f6e79223c605582109da4adb93b9d
Author: Ales Kozumplik <akozumpl@redhat.com>
Date:   Tue Feb 28 10:06:39 2012 +0100

    we are experimenting so do not check for root
    
    :nomerge
Comment 2 Ales Kozumplik 2013-06-18 03:56:44 EDT
no, the :nomerge comment just means this shouldn't be merged back to yum.

Parag, not checking for root is on purpose, see bug 910133 and the discussion there.

*** This bug has been marked as a duplicate of bug 910133 ***

Note You need to log in before you can comment on or make changes to this bug.