This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 97352 - (NET 8139TOO) 8139too driver broken in bootnet.img for kickstart install of RedHat 8.0
(NET 8139TOO) 8139too driver broken in bootnet.img for kickstart install of R...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-13 11:25 EDT by Need Real Name
Modified: 2013-07-02 22:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-23 12:21:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-06-13 11:25:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; fr-FR; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
We have successfully deployed RedHat 7.3 on serveral hundred of workstations
using Kickstart with DHCP/NFS , including 50 with a RealTeck network card with a
RTL 8139 chipset.

With RedHat 8.0 , these network cards are indeed detected but all
DHCP requests fail... If we enter the appropriate IP/gateway , NFS mounting fail... 

So we suspect the driver provided in bootnet.img to be broken.

No problem on the same machine with Kickstart install of redHat 7.2, 7.3 or 9.0 ! 

Problem is we cannot use RedHat 9 due to some software that do not 
function with the latest kernel (?) such as Kylix 3 or MyODBC ( complaining
about GLIBC symbols not defined...)






Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.use regular procedure to dd the bootnet.img
2.reply either yes or no to " do you have a driver disk"
3.make no difference since 8139too is on bootnet.img

    

Actual Results:  failure of dhcp request... 

Additional info:
Comment 1 Michael Fulbright 2003-06-13 12:24:47 EDT
Jeremy do you know of any issues related to this hw?
Comment 2 Kaj J. Niemi 2003-06-23 09:39:33 EDT
Are you able to disabe APIC and/or MPS 1.1/1.4 in BIOS?

This sounds awfully similar to the trouble I had with Shuttle
<http://www.shuttle.com/> manufactured PCs. At that time the Pentium 4s weren't
HT capable this was a good workaround at install time and has been working well
since. AFAIR this was actually a "feature" of the 8139 driver used, RH had the
"wrong" one I think. 

Latest Shuttle designs SB61G2 support 800 FSB P4s with HT so I guess I'll have
to revisit this problem soon. They're still using the same el cheapo integrated
RT 8139 ethernet controller instead of something bluechip (like e100/e1000) ;-)
Comment 3 Need Real Name 2003-06-23 12:21:55 EDT
Congratulations Kaj,
    This fixed my problem.

   Test 1: on the BIOS (Award BIOS, advanced setting) we disabled APIC and
Kickstart install works nicely: DHCP,NFS and post install.

    Test 2: I added "noapic" on the append line in the syslinux.cfg file for
these machines and left APIC enabled in BIOS.  Install is still OK, and when
rebooting the network card runs smootly.
  
   So the 3189too driver on the kickstart disquette are "APIC unaware", but the
drivers installed are "APIC aware", so no need to disable it for good in the BIOS


Thanks again for a real good advice.
Take care.

Note You need to log in before you can comment on or make changes to this bug.