Bug 973532 - [abrt] usermode-gtk-1.111-1.fc18: handle_error: Process /usr/bin/consolehelper-gtk was killed by signal 5 (SIGTRAP)
[abrt] usermode-gtk-1.111-1.fc18: handle_error: Process /usr/bin/consolehelpe...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
abrt_hash:b7f5aaf2198de43adecfa925e4b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 03:45 EDT by Mohammed Arafa
Modified: 2013-06-14 18:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 18:47:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (39.95 KB, text/plain)
2013-06-12 03:46 EDT, Mohammed Arafa
no flags Details
File: cgroup (130 bytes, text/plain)
2013-06-12 03:46 EDT, Mohammed Arafa
no flags Details
File: core_backtrace (3.63 KB, text/plain)
2013-06-12 03:46 EDT, Mohammed Arafa
no flags Details
File: dso_list (6.69 KB, text/plain)
2013-06-12 03:46 EDT, Mohammed Arafa
no flags Details
File: environ (2.43 KB, text/plain)
2013-06-12 03:46 EDT, Mohammed Arafa
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-12 03:46 EDT, Mohammed Arafa
no flags Details
File: maps (32.55 KB, text/plain)
2013-06-12 03:46 EDT, Mohammed Arafa
no flags Details
File: open_fds (333 bytes, text/plain)
2013-06-12 03:46 EDT, Mohammed Arafa
no flags Details
File: proc_pid_status (939 bytes, text/plain)
2013-06-12 03:46 EDT, Mohammed Arafa
no flags Details
xdpy output (60.11 KB, text/plain)
2013-06-14 04:19 EDT, Mohammed Arafa
no flags Details

  None (edit)
Description Mohammed Arafa 2013-06-12 03:45:56 EDT
Version-Release number of selected component:
usermode-gtk-1.111-1.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        system-config-network
crash_function: handle_error
executable:     /usr/bin/consolehelper-gtk
kernel:         3.9.4-200.fc18.x86_64
runlevel:       N 5
uid:            1000
var_log_messages: Jun 12 09:27:37 localhost abrt[1563]: Saved core dump of pid 1556 (/usr/bin/consolehelper-gtk) to /var/tmp/abrt/ccpp-2013-06-12-09:27:36-1556 (12312576 bytes)
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 handle_error at xcb_io.c:213
 #5 handle_response at xcb_io.c:325
 #7 XQueryPointer at QuPntr.c:48
 #8 _gdk_windowing_get_pointer at gdkwindow-x11.c:3163
 #9 gdk_display_get_pointer at gdkdisplay.c:513
 #10 get_monitor_containing_pointer at gtkwindow.c:5742
 #11 center_window_on_monitor at gtkwindow.c:5764
 #12 gtk_window_compute_configure_request at gtkwindow.c:5886
 #13 gtk_window_move_resize at gtkwindow.c:6054
 #14 gtk_window_check_resize at gtkwindow.c:5408
Comment 1 Mohammed Arafa 2013-06-12 03:46:03 EDT
Created attachment 759975 [details]
File: backtrace
Comment 2 Mohammed Arafa 2013-06-12 03:46:06 EDT
Created attachment 759976 [details]
File: cgroup
Comment 3 Mohammed Arafa 2013-06-12 03:46:11 EDT
Created attachment 759977 [details]
File: core_backtrace
Comment 4 Mohammed Arafa 2013-06-12 03:46:14 EDT
Created attachment 759978 [details]
File: dso_list
Comment 5 Mohammed Arafa 2013-06-12 03:46:18 EDT
Created attachment 759979 [details]
File: environ
Comment 6 Mohammed Arafa 2013-06-12 03:46:21 EDT
Created attachment 759980 [details]
File: limits
Comment 7 Mohammed Arafa 2013-06-12 03:46:27 EDT
Created attachment 759981 [details]
File: maps
Comment 8 Mohammed Arafa 2013-06-12 03:46:30 EDT
Created attachment 759982 [details]
File: open_fds
Comment 9 Mohammed Arafa 2013-06-12 03:46:35 EDT
Created attachment 759983 [details]
File: proc_pid_status
Comment 10 Miloslav Trmač 2013-06-12 15:39:32 EDT
Thanks for the report.

Is the crash reproducible?  If so, how?

Do you have any non-default X server setup (e.g. remote access, unusal server or configuration)?  Can you attach the output of (xdpyinfo -queryExtensions) with the same $DISPLAY, please?


(Notes to self.
* The error data is in _XError()'s event.xerror, the BadValue value in event.xerror.resourceid; per my xdpyinfo it would be an MIT-SHM:ShmPutImage, nothing obvious about "1536".
* If reproducible, next step would be to run X in synchronous mode, which would probably involve patching /usr/bin/consolehelper-x11; the GDK standard --sync is not passed through.)
Comment 11 Mohammed Arafa 2013-06-14 04:19:39 EDT
Created attachment 761134 [details]
xdpy output

requested xdpyinfo output
Comment 12 Mohammed Arafa 2013-06-14 04:23:38 EDT
crash reproducible .. it was repeated a few times on the first day. then i completed my personal configurations on the box to mirror applications and settings on my laptop. it stopped then.

non-default server setup no this was a fresh install from the live kde 64 bit dvd.

xdpyinfo attached
Comment 13 Mohammed Arafa 2013-06-14 04:27:19 EDT
hmm.. maybe it stopped because i uninstalled apper? after i disabled packagekit?
Comment 14 Miloslav Trmač 2013-06-14 18:47:08 EDT
(In reply to Mohammed Arafa from comment #12)
> crash reproducible .. it was repeated a few times on the first day. then i
> completed my personal configurations on the box to mirror applications and
> settings on my laptop. it stopped then.

Thanks for the information.

> non-default server setup no this was a fresh install from the live kde 64
> bit dvd.

I have attempted to reproduce this as well, using F18 KDE live DVD, and
1) only installing system-config-network, not updating anything else
2) installing GNOME (which dragged in some updates)
3) fully updating the system

In all cases in KDE, and after 3) in GNOME (before I couldn't start it) system-config-network successfully launched.


So, while the crash has obviously happened, I don't know how to debug it with the existing information, and there is no obvious way to get more information.

Closing this report as WORKSFORME, however if you find any way to reproduce this, please do reopen it.

Note You need to log in before you can comment on or make changes to this bug.