Bug 973537 - [abrt] autofs-5.0.7-20.fc19: mount_mount: Process /usr/sbin/automount was killed by signal 11 (SIGSEGV)
[abrt] autofs-5.0.7-20.fc19: mount_mount: Process /usr/sbin/automount was kil...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
abrt_hash:d51a9d8fa2d70a35d134b61f87e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 03:55 EDT by James Heather
Modified: 2013-07-07 20:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: autofs-5.0.7-23.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 20:51:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (63.40 KB, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
File: cgroup (158 bytes, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
File: core_backtrace (1000 bytes, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
File: dso_list (2.59 KB, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
File: environ (201 bytes, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
File: maps (14.44 KB, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
File: open_fds (176 bytes, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
File: proc_pid_status (896 bytes, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
File: var_log_messages (3.03 KB, text/plain)
2013-06-12 03:55 EDT, James Heather
no flags Details
Patch - fix probe each nfs version in turn for singleton mounts. (1.16 KB, patch)
2013-06-12 05:27 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Description James Heather 2013-06-12 03:55:01 EDT
Description of problem:
I don't know. I ran a yum update, which included autofs; then I rebooted; and autofs crashed on startup.

Version-Release number of selected component:
autofs-5.0.7-20.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/sbin/automount --pid-file /run/autofs.pid
crash_function: mount_mount
executable:     /usr/sbin/automount
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (7 frames)
 #0 mount_mount at mount_nfs.c:193
 #1 sun_mount at parse_sun.c:695
 #2 parse_mount at parse_sun.c:1612
 #3 lookup_mount at lookup_file.c:1130
 #4 lookup_name_file_source_instance at lookup.c:720
 #5 lookup_nss_mount at lookup.c:912
 #6 do_mount_indirect at indirect.c:776
Comment 1 James Heather 2013-06-12 03:55:05 EDT
Created attachment 759997 [details]
File: backtrace
Comment 2 James Heather 2013-06-12 03:55:08 EDT
Created attachment 759998 [details]
File: cgroup
Comment 3 James Heather 2013-06-12 03:55:11 EDT
Created attachment 759999 [details]
File: core_backtrace
Comment 4 James Heather 2013-06-12 03:55:14 EDT
Created attachment 760000 [details]
File: dso_list
Comment 5 James Heather 2013-06-12 03:55:17 EDT
Created attachment 760001 [details]
File: environ
Comment 6 James Heather 2013-06-12 03:55:20 EDT
Created attachment 760002 [details]
File: limits
Comment 7 James Heather 2013-06-12 03:55:23 EDT
Created attachment 760003 [details]
File: maps
Comment 8 James Heather 2013-06-12 03:55:26 EDT
Created attachment 760004 [details]
File: open_fds
Comment 9 James Heather 2013-06-12 03:55:29 EDT
Created attachment 760005 [details]
File: proc_pid_status
Comment 10 James Heather 2013-06-12 03:55:32 EDT
Created attachment 760006 [details]
File: var_log_messages
Comment 11 Ian Kent 2013-06-12 05:27:38 EDT
Created attachment 760042 [details]
Patch - fix probe each nfs version in turn for singleton mounts.
Comment 12 Ian Kent 2013-06-12 05:32:43 EDT
I'm not sure if this simple mistake is the only problem but
could you give this Rawhide build a try please. It can be
found at:
http://koji.fedoraproject.org/koji/buildinfo?buildID=426132
Comment 13 James Heather 2013-06-12 08:38:32 EDT
I've installed it... I'll see what happens! The crash isn't immediate, so I'll leave it for a few hours and see if it's stable.
Comment 14 James Heather 2013-06-12 15:08:09 EDT
This does seem to have fixed it, thanks! Now when it fails to find the hostname, it doesn't kill the process.



[root@zoe avocs]# systemctl status autofs
autofs.service - Automounts filesystems on demand
   Loaded: loaded (/usr/lib/systemd/system/autofs.service; enabled)
   Active: active (running) since Wed 2013-06-12 16:11:09 BST; 3h 54min ago
  Process: 1254 ExecStart=/usr/sbin/automount $OPTIONS --pid-file /run/autofs.pid (code=exited, status=0/SUCCESS)
 Main PID: 1276 (automount)
   CGroup: name=systemd:/system/autofs.service
           └─1276 /usr/sbin/automount --pid-file /run/autofs.pid

Jun 12 16:11:09 zoe automount[1276]: lookup_read_master: lookup(nisplus): couldn't locat...ter
Jun 12 16:11:09 zoe systemd[1]: Started Automounts filesystems on demand.
Jun 12 16:18:25 zoe automount[1276]: add_host_addrs: hostname lookup failed: Name or ser...own
Jun 12 16:19:34 zoe automount[1276]: add_host_addrs: hostname lookup failed: Name or ser...own
Jun 12 19:56:32 zoe automount[1276]: add_host_addrs: hostname lookup failed: Name or ser...own
[root@zoe avocs]#
Comment 15 Ian Kent 2013-06-12 21:49:04 EDT
(In reply to James Heather from comment #14)
> This does seem to have fixed it, thanks! Now when it fails to find the
> hostname, it doesn't kill the process.

OK, unless there is something else I'll apply the change to f19?

Ian
Comment 16 James Heather 2013-06-13 02:22:52 EDT
Yes please!
Comment 17 Fedora Update System 2013-06-13 03:11:40 EDT
autofs-5.0.7-21.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/autofs-5.0.7-21.fc19
Comment 18 Fedora Update System 2013-06-13 14:03:50 EDT
Package autofs-5.0.7-21.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing autofs-5.0.7-21.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10754/autofs-5.0.7-21.fc19
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2013-06-19 00:14:04 EDT
autofs-5.0.7-22.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/autofs-5.0.7-22.fc19
Comment 20 Fedora Update System 2013-06-28 01:58:47 EDT
autofs-5.0.7-23.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/autofs-5.0.7-23.fc19
Comment 21 Fedora Update System 2013-07-07 20:51:44 EDT
autofs-5.0.7-23.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.