Bug 973542 - gnome-shell-3.8.3 fails to show login screen
gnome-shell-3.8.3 fails to show login screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-06-12 04:05 EDT by James Heather
Modified: 2013-06-13 08:24 EDT (History)
8 users (show)

See Also:
Fixed In Version: gnome-shell-3.8.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 02:34:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Heather 2013-06-12 04:05:13 EDT
Description of problem:

When I boot up, I don't get a Fedora login screen. I just get a black screen, with an old-style X-Windows cross-hair cursor.

Version-Release number of selected component (if applicable):

3.8.3-1.fc19

How reproducible:

100% for me...

Steps to Reproduce:
1. update to 3.8.3-1.fc19
2. reboot
3. weep for mummy

Actual results:

No login screen (black screen till I touch the trackpad; then a cross-hair cursor)

Expected results:

Login screen

Additional info:

Solved by downgrading to 3.8.2-3.fc19. (This might be related to the gnome-classic-session update; I'm not sure.)

I don't know what else you need. There doesn't seem to be anything interesting in the X log or the gdm log, but I can provide files if that would be useful.
Comment 1 Kalev Lember 2013-06-12 08:50:32 EDT
I ran into the same issue and poked at it a bit. gnome-shell is crashing in cogl/clutter:

> $ gnome-shell --replace
> 
> GLib-CRITICAL **: g_strsplit: assertion `string != NULL' failed
> 
> Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined

It seems to be caused by the latest cogl build that enabled the wayland backend for F19. The previous gnome-shell build that does not crash for me is built against the X11-only cogl; the crashing version is built against the wayland-enabled cogl.
Comment 2 Kalev Lember 2013-06-12 09:12:12 EDT
The fix is in two packages:

cogl-1.14.0-3.fc19 -- disables the wayland backend (it was never meant
                      for F19, got accidentally enabled in the -2 build)
gnome-shell-3.8.3-2.fc19 -- rebuilt against the fixed cogl
Comment 3 Fedora Update System 2013-06-12 09:42:14 EDT
gnome-shell-3.8.3-2.fc19,cogl-1.14.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-shell-3.8.3-2.fc19,cogl-1.14.0-3.fc19
Comment 4 Fedora Blocker Bugs Application 2013-06-12 09:52:13 EDT
Proposed as a Blocker for 19-final by Fedora user kalev using the blocker tracking app because:

 This update fixes a crasher at gnome-shell startup that could possibly affect a number of people.
Comment 5 Adam Williamson 2013-06-12 12:30:25 EDT
Discussed at 2013-06-12 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-12/f19final-blocker-review-5.2013-06-12-16.01.log.txt . Accepted as a blocker per Alpha criterion "After firstboot is completed and on subsequent boots, a graphical install must boot to a log in screen where it is possible to log in to a working desktop as the user created during firstboot.": https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria#Expected_installed_system_boot_behavior .
Comment 6 Fedora Update System 2013-06-13 02:34:56 EDT
gnome-shell-3.8.3-2.fc19, cogl-1.14.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 James Heather 2013-06-13 08:24:59 EDT
Confirmed working here.

Note You need to log in before you can comment on or make changes to this bug.