Bug 973584 - Lightdm leaks 6 FDs
Lightdm leaks 6 FDs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
19
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Patch, Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 05:11 EDT by Rumen B.
Modified: 2013-10-18 15:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: lightdm-1.6.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-12 00:25:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for the leaking sockets (963 bytes, patch)
2013-06-12 11:14 EDT, Rumen B.
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1190344 None None None Never

  None (edit)
Description Rumen B. 2013-06-12 05:11:23 EDT
Description of problem:
Each time the greeter starts the number of open FDs increase. After each login and logout cycle the number of open FDs is increased by 6. Which over time leads to impossible logins and the message in /var/log/messages is:

Jun 12 02:44:24 node3 lightdm[17471]: ** (lightdm:17471): WARNING **: Failed to create pipe to communicate with session process: To...en files
Jun 12 02:45:29 node3 lightdm[17471]: ** (lightdm:17471): WARNING **: Failed to create pipes: Too many open files
Jun 12 02:47:47 node3 lightdm[17471]: ** (lightdm:17471): WARNING **: Failed to create pipes: Too many open files


Version-Release number of selected component (if applicable):
Fedora 19 lightdm 1.6.0

How reproducible: always

Steps to Reproduce:

1. login on a console and find the pid of main lightdm process then:
# lsof -p {lightdm_pid} |grep FIFO |wc -l
26

2. switch to X console and login through lightdm and then logout

3. go back on comsole
# lsof -p {lightdm_pid} |grep FIFO |wc -l
32


Actually the number increases when the greeter is started but it never decreases.
Comment 1 Rumen B. 2013-06-12 11:14:56 EDT
Created attachment 760204 [details]
Fix for the leaking sockets

Here is a patch that fixes the issue reported by me earlier today. It may have several lines offset because we use modified lightdm but it is good for the original version too.

regards,
Rumen
Comment 2 Rumen B. 2013-06-12 11:28:13 EDT
Sorry I mean Leaking File descriptors :)
Comment 3 Gregor Tätzner 2013-06-12 11:56:33 EDT
Cool, can you submit that patch upstream?
Comment 4 Rumen B. 2013-06-12 13:32:13 EDT
Probably I can, but i do not know how. Can you shed some light how to do so.
Comment 5 Gregor Tätzner 2013-06-12 15:03:45 EDT
Create or search a bug on launchpad [1] and attach your patch

[1] https://bugs.launchpad.net/lightdm
Comment 6 Fedora Update System 2013-10-05 22:50:49 EDT
lightdm-1.7.17-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lightdm-1.7.17-2.fc20
Comment 7 Fedora Update System 2013-10-06 01:32:09 EDT
Package lightdm-1.7.17-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.7.17-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18432/lightdm-1.7.17-2.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-10-08 17:04:39 EDT
lightdm-1.6.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lightdm-1.6.3-2.fc19
Comment 9 Fedora Update System 2013-10-09 10:23:01 EDT
Package lightdm-1.7.18-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.7.18-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18432/lightdm-1.7.18-2.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-10-09 16:44:29 EDT
lightdm-1.8.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lightdm-1.8.0-2.fc20
Comment 11 Fedora Update System 2013-10-12 00:25:51 EDT
lightdm-1.8.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-10-18 15:35:05 EDT
lightdm-1.6.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.