Bug 973589 - [RFE] Provide PXE Server Information via API
[RFE] Provide PXE Server Information via API
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Bryan Kearney
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 05:21 EDT by james labocki
Modified: 2016-10-07 09:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-07 09:16:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2013-06-12 05:21:33 EDT
This is a request to provide information about the PXE server via Satellite's API if it is being utilized. This information is required by CloudForms and could assist with automatic discovery and configuration of Satellite as a provisioning method within CloudForms. Information required includes:

Name: 

Access URL - http accessible address of PXE server.
URI - for SMB or NFS access.
PXE Directory - Directory of PXE server.
Windows Images Directory - Directory containing windows images.
Customization Directory - Directory where PXE records can be written.
Filename - menu file name for PXE server.
Comment 1 RHEL Product and Program Management 2013-06-12 14:33:17 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Ohad Levy 2013-06-24 02:34:48 EDT
I'm not sure if it makes a lot of sense to expose this information directly via the api.

In Sat6 arch, we support multiple pxe servers (e.g. across locations) and the content and settings (e.g. boot files / pxe config files) are auto generated and maintained.

exposing the information and allow to change it directly (e.g. not part of a bigger os / host life cycle) is not advised.

Can you elaborate more on how you would like to consume that information?

thanks.
Comment 4 james labocki 2013-06-24 14:59:04 EDT
The thought is that provisioning may be initiated from a system that is not Satellite, but want to utilize the underlying PXE server within Satellite to perform the provisioning. 

Where SystemX is a system that wants to utilize the PXE server within Satellite to provision a workload and SystemY is the provision system it seems this could be done by:

Scenario A
 1. SystemX ----Discover----> Satellite6
 2. SystemX ----Write-------> Appropriate PXE Server
 3. SystemX --Provision VM--> Virtualization/IaaS/MaaS Provider
 4. SystemY --Register -----> Satellite6

Scenario B
 1. SystemX    ----Request-----> Satellite6
 2. Satellite6 ---Write--------> Appropriate PXE Server
 3. Satellite6 ---Acknowledge--> SystemX
 4. SystemX    --Provision VM--> Virutalization/IaaS/MaaS Provider
 5. SystemY    --Register -----> Satellite6

At my first analysis it seems like Scenario A might be beneficial in that SystemX doesn't need to wait for a response from Satellite 6 in order to utilize the PXE server provided.

How would you envision SystemX provisioning via Satellite6?
Comment 5 Mike McCune 2013-08-16 14:00:56 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 6 Mike McCune 2013-08-26 11:23:03 EDT
moving to
Comment 8 Bryan Kearney 2016-10-07 09:16:13 EDT
Closing out an old bug. If this is still needed, please feel free to re-open with additional information.

Note You need to log in before you can comment on or make changes to this bug.