Bug 973597 - [rhsc] when a gluster swift service is removed from the server, event log says Not_available instead of not_installed.
[rhsc] when a gluster swift service is removed from the server, event log say...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Shubhendu Tripathi
RamaKasturi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 05:58 EDT by RamaKasturi
Modified: 2013-09-23 18:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: bb6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15549 None None None Never

  None (edit)
Description RamaKasturi 2013-06-12 05:58:11 EDT
Description of problem:
 when a gluster swift service is removed from the server, event log says Not_available instead of not_installed.

Version-Release number of selected component (if applicable):
rhsc-2.1.0-0.bb3.el6rhs.noarch
glusterfs-3.4.0.9rhs-1.el6rhs.x86_64
vdsm-4.10.2-22.3.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. ssh to server, from which the gluster swift service should be removed.
2. yum remove gluster-swift-account. to remove the service.
3.

Actual results:
Status of service gluster-swift-account on server Node2 changed from RUNNING to NOT_AVAILABLE. Updating in engine now.

Expected results:
Status of service gluster-swift-account on server Node2 changed from RUNNING to NOT_INSTALLED. Updating in engine now.

Additional info:
Comment 2 Sahina Bose 2013-07-17 05:46:03 EDT
Fixed in bb6
Comment 3 RamaKasturi 2013-07-19 08:29:20 EDT
Verified in bb6. 
Glusterfs - glusterfs-3.4.0.12rhs.beta4-1.el6rhs.x86_64
vdsm - vdsm-4.10.2-23.0.1.el6rhs.x86_64
Comment 4 Scott Haines 2013-09-23 18:25:48 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.