Bug 973618 - no restart and shutdown opition in lightdm menu
no restart and shutdown opition in lightdm menu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
19
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-06-12 07:10 EDT by Wolfgang Ulbrich
Modified: 2014-03-14 09:05 EDT (History)
9 users (show)

See Also:
Fixed In Version: lightdm-1.6.0-10.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-21 22:32:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lightdm.log (3.02 KB, text/x-log)
2013-06-12 07:14 EDT, Wolfgang Ulbrich
no flags Details
x-0.log (3.88 KB, text/x-log)
2013-06-12 07:15 EDT, Wolfgang Ulbrich
no flags Details
x-0-greeter.log (2.21 KB, text/x-log)
2013-06-12 07:16 EDT, Wolfgang Ulbrich
no flags Details

  None (edit)
Description Wolfgang Ulbrich 2013-06-12 07:10:10 EDT
Description of problem:
After a fresh installed MATE desktop from f19 netiso TC2, shutdown and restart options didn't displayed in lightdm panel menu.
In /var/log/lightdm/x-0-greeter.log i found this warning.

** (process:468): WARNING **: Failed to open CK session: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files

Installing consolekit-x11 fix the issue, after a restart the menu items displayed well are working.

Also 'suspend on lid close' didn't work without consolekit, but i'm not shure if this lightdm related.

Version-Release number of selected component (if applicable):
lightdm-1.6.0-9.fc19.x86_64

How reproducible:



Steps to Reproduce:
1. Install MATE Desktop from netinstall iso f19 TC2 and reboot.
2. try to to restart/shutdown from lightdm panel menu.

Actual results:
no shutdown/restart option in panel menu

Expected results:
shutdown/restart option in panel menu

Additional info:
Comment 1 Wolfgang Ulbrich 2013-06-12 07:14:56 EDT
Created attachment 760098 [details]
lightdm.log
Comment 2 Wolfgang Ulbrich 2013-06-12 07:15:54 EDT
Created attachment 760099 [details]
x-0.log
Comment 3 Wolfgang Ulbrich 2013-06-12 07:16:39 EDT
Created attachment 760100 [details]
x-0-greeter.log
Comment 4 Kevin Fenzi 2013-06-20 14:34:52 EDT
I'm seeing this also on a TC6 xfce spin install.
Comment 5 Rex Dieter 2013-06-20 14:37:43 EDT
I can confirm now:

* selinux isnt it (enabled/permissive doesn't matter)
* polkit.rules seems correct

Now, testing different bindings (gtk/gobject vs qt/kde).

* gtk/gobject doesnt work
Comment 6 Rex Dieter 2013-06-20 14:41:04 EDT
A ha!

* lightdm-kde works

OK, time to re-review the systemd-login patch to lightdm-gobject bindings
Comment 7 Rex Dieter 2013-06-20 14:50:15 EDT
For example, working -qt bindings code example:

if ( d->login1Interface->isValid() ) {
  QDBusReply<QString> reply1 = d->login1Interface->call("CanReboot");
  if (reply1.isValid()) {
    return (reply1.value()=="yes");
  }
}


-gobject bindings equivalent:

/**
* CanReboot, CanPowerOff returns a string "yes", "no", or "challenge", not a boolean as ConsoleKit
**/
if (g_variant_is_of_type (result, G_VARIANT_TYPE ("(s)"))) {
    g_variant_get (result, "(b)", str_result);
    if(g_strcmp0(str_result,true_result) == 0) {
        function_result = TRUE;
    }
...


Now, I get to wrap by brain around how this g_variant stuff is supposed to work again. :-/
Comment 8 Fedora Update System 2013-06-20 16:25:25 EDT
lightdm-1.6.0-10.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lightdm-1.6.0-10.fc19
Comment 9 Rex Dieter 2013-06-20 16:41:24 EDT
nominating blocker, xfce/mate spins won't be able to shutdown/restart from login screen without this fix.
Comment 10 Kevin Fenzi 2013-06-21 15:16:22 EDT
+1 FE (since it's non blocking desktops, I don't think it can really be a blocker)
Comment 11 Fedora Update System 2013-06-21 15:17:05 EDT
Package lightdm-1.6.0-10.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.6.0-10.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11449/lightdm-1.6.0-10.fc19
then log in and leave karma (feedback).
Comment 12 Dan Mashal 2013-06-21 15:17:31 EDT
+1
Comment 13 Adam Williamson 2013-06-21 17:12:57 EDT
+1 here too, setting accepted freeze exception.
Comment 14 Mukundan Ragavan 2013-06-21 18:44:54 EDT
1.6.0-10 fixes the issue. restart and shutdown options are back.
Comment 15 Adam Williamson 2013-06-21 18:47:32 EDT
thanks! setting VERIFIED. can you up-karma the update if you didn't already?
Comment 16 Fedora Update System 2013-06-21 22:32:08 EDT
lightdm-1.6.0-10.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Steve Rogerson 2013-08-08 04:20:59 EDT
I still get this problem:
kernel 3.10.4-300.fc19.x86_64
$ rpm -q lightdm
lightdm-1.6.0-10.fc19.x86_64

Suspend works with gnome, not with MATE

lenovo G570 laptop.

Fn-F1: beeps and (sometimes) produces a window with "Failure reported as: Cannot suspend"

No sleep/hibernate options in the shutdown window. Same with and without ConsoleKit-x11.

selinux not enforced. Nothing in any log looks helpful.
Comment 18 Steven Franzen 2014-03-13 09:15:38 EDT
I also still have this issue on Fedora 20 with KDE and lightdm 1.8.5-2. It must still be something to do with permissions, as the buttons are present and working when I run $ lightdm -d --test-mode.
Comment 19 Rex Dieter 2014-03-13 09:34:18 EDT
Steven, please file a separate bug, yours is likely different
Comment 20 Steven Franzen 2014-03-14 09:05:06 EDT
(In reply to Rex Dieter from comment #19)
> Steven, please file a separate bug, yours is likely different

Done (1076493).

Note You need to log in before you can comment on or make changes to this bug.