Bug 973622 - [RHSC] Gluster Swift Status in cluster general subtab shows incorrect status.
Summary: [RHSC] Gluster Swift Status in cluster general subtab shows incorrect status.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: Unspecified Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Shubhendu Tripathi
QA Contact: RamaKasturi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-12 11:11 UTC by RamaKasturi
Modified: 2013-09-23 22:25 UTC (History)
9 users (show)

Fixed In Version: bb5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 22:25:48 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attaching engine and vdsm logs (12.48 MB, text/x-log)
2013-06-12 11:11 UTC, RamaKasturi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15976 None None None Never

Description RamaKasturi 2013-06-12 11:11:10 UTC
Created attachment 760096 [details]
Attaching engine and vdsm logs

Description of problem:
Gluster Swift Status in cluster general subtab shows incorrect status.

Version-Release number of selected component (if applicable):
rhsc-2.1.0-0.bb3.el6rhs.noarch
glusterfs-3.4.0.9rhs-1.el6rhs.x86_64
vdsm-4.10.2-22.3.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a cluster with two nodes attached to it.
2. stop the all the services in one node and uninstall all the services in the other node.
3. Now go to cluster general subtab.

Actual results:
Gluster Swift Status is shown as partiallyup.

Expected results:
Gluster Swift Status should be shown Down.

Additional info:

Comment 2 RamaKasturi 2013-07-08 09:13:53 UTC
Working as expected in bb5 with vdsm 22.6

Comment 3 Scott Haines 2013-09-23 22:25:48 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html


Note You need to log in before you can comment on or make changes to this bug.