Bug 973629 - [RHSC] Incorrect events log message seen when a host moves from Non-Operational to UP.
[RHSC] Incorrect events log message seen when a host moves from Non-Operation...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Shubhendu Tripathi
Dustin Tsang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 07:28 EDT by Shruti Sampat
Modified: 2015-07-13 00:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: bb5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15828 None None None Never

  None (edit)
Description Shruti Sampat 2013-06-12 07:28:56 EDT
Description of problem:
---------------------------------------
When a host, that was in the Non-operational state, comes UP, the message seen in the Events log looks like this - 

Detected new Host <hostname>. Host state was set to Up.

Since it is not a new host that just came UP, the message should convey the correct information, that it was an existing host that was in the Non-Operational state, which just came UP.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb3.el6rhs 

How reproducible:
Always

Steps to Reproduce:
1. Add a host to a cluster via the Console and let it come UP.
2. Run the following command to stop glusterd on the host - 
   # service glusterd stop
3. After the host goes to the Non-Operational state, run the following command       to start glusterd - 
   # service glusterd start

Actual results:
The above described message is seen in the Events log.

Expected results:
The message should convey the right information as described above.

Additional info:
Comment 1 Shruti Sampat 2013-06-12 07:40:06 EDT
Same is the case when a host goes to UP state after being Non-responsive for a while.
Comment 3 Shubhendu Tripathi 2013-06-18 02:22:04 EDT
Once it comes to refreshing the status of a host it does not have details if the host is newly added or existing one. The status is changed to "Up" after refresh.

The only way to figure out if a host is newly added is the sequence in which the audit log messages are displayed.

In existing scenario, in case of newly added event log messages would be in the below sequence -

"Host <Host Name> was added by admin@internal." followed by 
"Detected new Host <Host Name>. Host state was set to Up."

Whereas in case of host just refreshed from Non-operational to Up would have an event log in the form -

"Detected new Host <Host Name>. Host state was set to Up."

---------------

As correctly identified the message "Detected new Host <Host Name>. Host state was set to Up." is misleading. We will modify the message as below -

"State was set to Up for <Host Name>".

So post changes the event logs in case of newly added host would be as below -

"Host <Host Name> was added by admin@internal." followed by 
"State was set to Up for <Host Name>".

and in case of host just refreshed from Non-operation to Up would be -

"State was set to Up for <Host Name>".

Confirm if the same is fine.
Comment 4 Shruti Sampat 2013-06-18 02:50:34 EDT
Looks good to me.
Comment 5 Dustin Tsang 2013-07-08 15:21:54 EDT
verified in rhsc-bb5
Comment 6 Scott Haines 2013-09-23 18:25:48 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.