Bug 973630 - When '/katello' part of the repo url, access to ks tree from foreman doesn't work
When '/katello' part of the repo url, access to ks tree from foreman doesn't ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 07:31 EDT by Ivan Necas
Modified: 2014-07-02 10:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:06:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
provision via http successful (126.93 KB, image/png)
2014-05-13 05:28 EDT, Kedar Bidarkar
no flags Details
the repos for this cv (76.01 KB, image/png)
2014-05-13 05:29 EDT, Kedar Bidarkar
no flags Details
the console (109.79 KB, image/png)
2014-05-13 05:31 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Ivan Necas 2013-06-12 07:31:19 EDT
Description of problem:
this happens when org, env, content view, product or repo label begin with 'katello' prefix.

Steps to Reproduce:
1. create a repo (published by http) with some distribution
2. create content view called katello, add the repo there
3. promote the content view
4. try to use the repo as installation media in foreman
(or try to access the repo through http)

Actual results:
http redirected to https (causing the tree not being available for provisioning)


Expected results:
provisioning works, access the repo through http works
Comment 1 Ivan Necas 2013-06-12 07:33:55 EDT
Fixed in https://github.com/Katello/katello-installer/pull/34
Comment 2 RHEL Product and Program Management 2013-06-12 14:33:12 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Mike McCune 2013-10-17 17:00:55 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 8 Kedar Bidarkar 2014-05-13 05:26:15 EDT
We are able to access the link via http now.
http://xxxx.redhat.com/pulp/repos/ACME_Corporation/Dev/cv-rhel65-ks-manifest/content/dist/rhel/server/6/6.5/x86_64/kickstart/

Also we are able to provision the vm's with the above link using it as Installation media.

so both provisioning and http access to the link works.
Comment 9 Kedar Bidarkar 2014-05-13 05:28:16 EDT
Created attachment 895073 [details]
provision via http successful
Comment 10 Kedar Bidarkar 2014-05-13 05:29:16 EDT
Created attachment 895074 [details]
the repos for this cv
Comment 11 Kedar Bidarkar 2014-05-13 05:31:06 EDT
Created attachment 895075 [details]
the console
Comment 12 Bryan Kearney 2014-07-02 10:06:28 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.