Bug 97364 - Upgrade from 7.2 to 9 crashes with [Errno 2] No such file or directory: '/mnt/sysimage/etc/mtab'
Summary: Upgrade from 7.2 to 9 crashes with [Errno 2] No such file or directory: '/mnt...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-13 18:16 UTC by Steve Barnes
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 23:06:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full anacdump (174.66 KB, text/plain)
2003-06-19 14:16 UTC, Steve Barnes
no flags Details

Description Steve Barnes 2003-06-13 18:16:25 UTC
Description of problem:
See Traceback below.

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1.Boot from 9 CD.
2.Choose linux upgradeany.
3.Anaconda crashes just before packages install.
        
Actual results:

Expected results:

Additional info:
The upgrade procedure also cannot find a boot loader (although GRUB is working 
fine) and it cannot find an /etc/redhat-release file (although there is one).

Following is the the first lines of anacdump.txt:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 936, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 155, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 761, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 225, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 596, in doPreInstall
    f = open(instPath + "/etc/mtab", "w+")
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/mtab'

Local variables in innermost frame:
upgrade: 1
intf: <gui.InstallInterface instance at 0x871393c>
select: <function select at 0x88a9cac>
method: <image.CdromInstallMethod instance at 0x835be94>
arch: i386
id: <instdata.InstallData instance at 0x871881c>
dir: 1
instPath: /mnt/sysimage

Comment 1 Jeremy Katz 2003-06-18 20:43:23 UTC
Can you attach the complete anacdump.txt?

Comment 2 Steve Barnes 2003-06-19 14:16:06 UTC
Created attachment 92486 [details]
full anacdump

Requested by: katzj@redhat.com	2003-06-18 16:43

Comment 3 Jeremy Katz 2003-07-03 05:09:59 UTC
Was /dev/hdb1 the correct partition to use as your root fs?

Comment 4 Steve Barnes 2003-07-13 21:02:12 UTC
Jeremy Katz asks:
Was /dev/hdb1 the correct partition to use as your root fs?


It shouldn't be. /dev/hdb1 is a slave drive intended only as an incoming 
directory for ftp. It was also added long after the initial install. 

I can understand why this would be causing 'file not found' messages.

Can I 're-assign' this drive?



Comment 5 Steve Barnes 2003-07-17 20:13:07 UTC
Jeremy

This is my mtab:

/dev/hda8 / ext3 rw 0 0
none /proc proc rw 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/hda1 /boot ext3 rw 0 0
/dev/hda6 /home ext3 rw 0 0
/dev/hda5 /usr ext3 rw 0 0
/dev/hda7 /var ext3 rw 0 0
none /dev/shm tmpfs rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/hdb1 /var/ftp/pub/incoming ext3 rw 0 0


anacdump says the following are mounted:

fsentry -- device: hdb1   mountpoint: /

fsentry -- device: hda1   mountpoint: /boot

fsentry -- device: none   mountpoint: /dev/pts

fsentry -- device: hda6   mountpoint: /home

fsentry -- device: none   mountpoint: /proc

fsentry -- device: hda5   mountpoint: /usr

fsentry -- device: hda7   mountpoint: /var

fsentry -- device: hda9   mountpoint: swap


What do you think has happened to hda8, which should be mounted on /

and why is hdb1 mounted on / when it should be on /var/ftp/pub/incoming?


Where does anaconda get its mount infornation from? 



Comment 6 Jeremy Katz 2003-07-17 20:23:19 UTC
It sounds like you have a label on /dev/hdb1 that's the same as the label on
hda8.    Running 'e2label /dev/foo' should give you the label on the disk.  I'm
guessing your fstab has the labels to mount?

Comment 7 Steve Barnes 2003-07-18 14:59:38 UTC
Yes, e2label gives / for /dev/hda8 and /dev/hdb1

However, this is my fstab:

LABEL=/		/		ext3    	defaults        	1 1
LABEL=/boot	/boot		ext3    	defaults        	1 2
LABEL=/home	/home           ext3    	defaults        	1 2
/dev/cdrom	/mnt/cdrom      iso9660 	noauto,owner,ro 	0 0
/dev/fd0	/mnt/floppy     auto    	noauto,owner    	0 0
LABEL=/usr	/usr            ext3    	defaults        	1 2
LABEL=/var	/var            ext3    	defaults        	1 2
none		/proc           proc    	defaults        	0 0
none		/dev/shm        tmpfs   	defaults        	0 0
none		/dev/pts        devpts  	gid=5,mode=620  	0 0
/dev/hda9	swap            swap    	defaults        	0 0
/dev/hdb1	/var/ftp/pub/incoming   ext3    defaults        	0 0


Comment 8 Jeremy Katz 2003-07-24 23:06:15 UTC
If you have more than one device with the same label, the results are not
deterministic.  It's a "don't do that" situtation.  I've added checks to the
installer to detect this, though, for the future.

Comment 9 Steve Barnes 2003-07-29 13:24:43 UTC
I've changed the following line in fstab:

LABEL=/    /    ext3    defaults    1 1

to:

/dev/hda8    /    ext3    defaults    1 1


All is now well with anaconda


Many thanks

Steve Barnes



Note You need to log in before you can comment on or make changes to this bug.