Bug 973702 - Puppet install on Fedora 19 fails with unrecognized flag for 'gem'
Puppet install on Fedora 19 fails with unrecognized flag for 'gem'
Status: CLOSED DUPLICATE of bug 952955
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 10:15 EDT by Hiro Asari
Modified: 2015-05-14 19:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 10:35:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hiro Asari 2013-06-12 10:15:39 EDT
Description of problem:

https://lists.openshift.redhat.com/openshift-archives/dev/2013-June/msg00049.html

Hello,

I'm trying to install origin on Fedora19 Beta since I just heard
current upstream master is now based on Fedora19, but I'm getting
following kind of errors on puppet install:

Error: /Stage[main]/Openshift_origin::Broker/Package[mysql]/ensure:
change from absent to present failed: Execution of '/bin/gem install
--include-dependencies --no-rdoc --no-ri mysql' returned 1: ERROR:
While executing gem ... (OptionParser::InvalidOption)
    invalid option: --include-dependencies

Is the upstream master based on Fedora19 rawhide but not Beta? or am I
missing something?

Thanks,
Tomo


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Hiro Asari 2013-06-12 10:17:44 EDT
RubyGems 2.x does not recognize '--include-dependencies' (which is now default).

Assigning this to Krishna.
Comment 2 Hiro Asari 2013-06-12 10:35:15 EDT

*** This bug has been marked as a duplicate of bug 952955 ***

Note You need to log in before you can comment on or make changes to this bug.